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LICENSE NOTICE, LIMITED WARRANTY AND
DISCLAIMER AND LIMITATION OF LIABILITY
Abracadata, Ltd. grants to Licensee the non-exclusive license
to use the Software on one computer and to make a backup
copy of the Software for Licensee’s own use. The “Licensee” is
the single individual or business entity for whom the Software
was originally purchased. All rights and protections under
federal, state and international law, including but not limited
to the law of copyright, patent, trademark, trade secret and
contract, shall remain in full force and effect. Licensee may not
download, reproduce, distribute, republish, sell, rent, lease,
sublicense, or translate the Software or documentation in
violation of those laws and this License. The Software remains
confidential, proprietary information, in which Abracadata,
Ltd., the authors, suppliers and developers of the Software
claim trade secret rights. Licensee may not modify, reverse
engineer, decompile or disassemble the Software.
Abracadata, Ltd. warrants to Licensee and to no other person
or entity that the physical media provided to Licensee (but not
the Software recorded on them or the documentation), are free
from defects in materials or workmanship for a period of 30
days from the original purchase date. Abracadata cannot
guarantee that the program will operate on all systems that
meet the minimum specifications indicated on the box. If
during this 30-day period a defect should occur, contact
Abracadata to obtain a return authorization number before
returning the product. Licensee’s sole remedy in the event of a
defect in the disk is limited to replacement of the disk. As
stated below, Abracadata disclaims any and all implied warranty is found to exist, it shall terminate no later than 30 days
after purchase. If the disk has been physically damaged, is
beyond the 30-day limit or is not accompanied by proof of
purchase, include $10.00 for each disk plus $3.00 postage and
handling per request. Please return the disk only, not the
entire package. Do not staple or paper clip the disk. Package
the disk carefully to prevent bending, and mark the package
Do Not X-Ray or Use Magnets. Ship via UPS or U.S. Postal
Service with return receipt requested. Abracadata, Ltd. is not
responsible for disks not received when Licensee cannot
provide proof of shipment and Abracadata, Ltd.s receipt.
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This Limited Warranty does not grant and specifically excludes any right to recover any other damages whatsoever,
including but not limited to, loss of profit, loss of information,
business interruption, or special, incidental, or consequential
damages or other similar claims, arising out of the use or
inability to use the Software or documentation, even if Abracadata, Ltd. has been specifically advised of such damages. In no
event shall Abracadata, Ltd.s liability for any damages to
Licensee or any other person ever exceed the actual price paid
for the Software, regardless of the form of the claim.
In all other respects, the Software and documentation is
licensed AS IS, WITH ALL FAULTS. ABRACADATA, LTD.
SPECIFICALLY DISCLAIMS ALL OTHER WARRANTIES
REGARDING THE SOFTWARE AND DOCUMENTATION,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
TO, ANY IMPLIED WARRANTY OF MERCHANTABILITY
OR FITNESS FOR A PARTICULAR PURPOSE. Abracadata,
Ltd. specifically makes no representation or warranty that the
Software is fit for any particular purpose.
This Limited Warranty gives Licensee specific legal rights.
Licensee may have others, which vary from state to state.
Because some states or provinces do not allow the exclusion or
limitation of liability for consequential or incidental damages,
or the limitation on duration of an implied warranty, some of
the limitations may not apply to Licensee.
Abracadata, Ltd. gives no assurance that the information used
in the development of the Software is reliable and accurate.
Any recommendations or suggested results in the Software
represent only the generic opinions and judgments of the
author and are intended to be applicable in a variety of circumstances. However, individual circumstances vary and may
render certain recommendations and results inapplicable.
Abracadata, Ltd. gives no assurance that the opinions or
judgments of the author are reliable or accurate.
If any provision of this License is held to be unenforceable, it
will be construed to have the broadest interpretation that
would make it valid and enforceable. Invalidity or
unenforceability of one provision will not affect any other
provision of this License. This License shall be governed by
the laws of the State of Oregon.
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Introduction
Welcome to Design Your Own Home® 3D WalkAround™!
You’ve purchased a powerful, flexible, easy-to-use tool for
drawing floorplans and architectural designs.
What can 3D WalkAround do?
3D WalkAround gives you the power to be creative! Whether
you want to add on to your existing home, build a new dream
home, or simply want to experiment with home or office
furniture arrangements, you’ve acquired the right program for
the job.
You can create your own floorplans, or select from 200
predrawn floorplans. Use them as is, edit them to suit your
needs, or just browse them for possible ideas.
The wall tool lets you create floorplan layouts quickly and
easily. It shows to-scale wall lengths as you draw. And since it
automatically snaps to wall end points, the creation of precise
corner connections is a breeze.
Once the floorplan is done, choose among hundreds of
predrawn to-scale furniture symbols from a variety of provided
symbol libraries. Add furniture to your designs with drag and
drop ease! Experiment with furniture arrangements, and simultaneously view the results in 3D (save your back and let your
mouse do the heavy lifting).
Also, pick from hundreds of realistic scanned textures such as
fabrics, wallpaper, carpet, floor tiles, brick, stones, wood
grains, and more. Customize your design. Apply textures to
walls, floors, and furniture.
Then, don’t simply imagine how it will look. Go for a virtual
3D walk-around in your creation and experience it!
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What are some of 3D WalkAround’s features?
Here are just a few of the many features you’ll find helpful for
creating your design projects: multiple layers, 24-bit color
support, numerous architectural scale choices, visible grid
points, grid snap, rulers that reflect “real world” distances, ruler
lines, dimension lines, text in different fonts and sizes, a special tool for drawing evenly-spaced studs and joists, a bezier
curve tool, multigon tool, 2D patterns, 3D textures, predrawn
2D and 3D symbols, the ability to create and save your own
custom symbols, convenient “cut and paste,” support for
multiple open documents, automatic rescaling of objects, 3D
viewing and walk-around features, and much more.

Technical Support
Abracadata appreciates your support and interest in using our
products! We provide free technical support so if you run into
problems, or have questions that you can’t find answers for in
this manual, help is only a phone call away.
Before calling though, please look through your manual for the
solution. You’ll find the answer to many of your questions and
problems here. If you are unable to find a satisfactory answer
in the manual, please gather the following information, then
call the technical support number below for assistance.
1. Determine the version of 3D WalkAround you have.
2. Have your computer and system configuration information
available. We may need to know what model of Macintosh you
have, and what version of system software you are using. If
uncertain about what version of system software you have,
select About the Finder under the Finder’s Apple menu.
3. Know which, if any, Inits or Extensions are on your system.
These can be thought of as utility programs, which typically
modify standard system operation in some fashion. You may
see their icons appear along the bottom of the screen when you
11

start your computer. It’s not unusual for them to cause compatibility problems between themselves or other applications.
They are located inside your System Folder.
4. Call Abracadata’s technical support number between
8:30 AM and 4:30 PM Pacific time: 541-342-3030. Please
don’t call our order lines for technical support. These employees are not trained for technical support. Unlike some companies, we don’t charge for support. We only ask that you pay for
the call so that we may continue to provide economical products
for you and all our customers.
About the Team
Design Your Own Home, 3D WalkAround is brought to you by
a team of professional designers, programmers, writers, testers,
and other business professionals who pride themselves in
providing software that is dynamic, easy-to-use, and enriches a
particular aspect of your life.
We would love to hear from you about 3D WalkAround or any
other Abracadata products that you use. And here’s why: Most
software is continuously updated and enhanced over time. And
YOU are one of the best sources of information for enhancement ideas. We wrote the software for you; so if you want new
features or have suggestions about how you’d like to see the
program work in the future, please let us know.

12
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Chapter 1
Getting Started
If you are familiar with the Macintosh’s desktop environment,
you’ll feel right at home using 3D WalkAround. If you haven’t
used a mouse or worked within a desktop environment, please
refer to your computer’s User’s Guide. It provides more indepth information about printing, loading and saving documents, and other Macintosh features.
This manual’s primary focus is on specific information you
need to use 3D WalkAround.

Installation
To install 3D WalkAround onto your hard disk:
1. Insert the 3D WalkAround CD-ROM disk into your drive
and double-click the CD-ROM disk icon.

2. If a ReadMe file is present, double-click it and read the
provided information. The ReadMe file may contain updated
system requirements, or revised installation or usage instructions too recent to make it into this manual.
3. Depending on the type of Macintosh computer you have,
drag the appropriate folder to the desired hard disk location. If you have a Power Macintosh, drag the folder named
“3D WalkAround.pm” to your hard disk. If you have a 68K
Macintosh, drag the folder named “3D WalkAround.68K” to
your hard disk.
14
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4. If desired, install the predrawn floorplans. You’ll see two
folders, named “Floorplans.68k” and “Floorplans.pm” . Select
“Floorplans.pm” if you are using a Power Macintosh, and
“Floorplans.68k” if you are using a 68k Maintosh. It requires
approximately 6.5 MB of disk space. You can install the
floorplans on your hard disk, or access them directly from the
CD-ROM while using 3D WalkAround. To install, simply drag
the Floorplans folder to the desired hard disk location.

Starting 3D WalkAround
To start 3D WalkAround:
1. Find and double-click the 3D WalkAround folder. Find
the “3D WalkAround.pm” folder or the “3D
WalkAround.68K” folder, depending on which you installed.
Double-click the folder to open a window containing 3D
WalkAround and its associated files.

The 3D WalkAround folder contains:
Samples
a folder containing sample designs
Symbol Libraries
Images3D

a folder containing symbols
a folder containing 3D symbols

Textures

a folder containing 3D textures

15
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3D WalkAround application the 3D WalkAround program
2. Double-click the 3D WalkAround application icon to start
3D WalkAround.

Useful Tip: Designs that you save to disk appear with a document icon when viewed from the Finder screen. You can
double-click a document icon to start 3D WalkAround and have
the drawing load automatically. Here’s a sample document
icon:

16
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Chapter 2
3D WalkAround Tutorial
We recommend that you work through this tutorial chapter
from the beginning to the end, since many sections build on
information introduced in earlier sections. Because this is
intended to be a hands-on chapter, you should have 3D
WalkAround running and actually perform the operations that
describe how to create a simple floor plan.
Note: If you make a mistake, immediately select Undo to
reverse it (or hold the command key and press “Z”). Don’t
click anywhere or do any other operation before selecting
Undo or you may not be able to reverse the mistake. The Undo
menu item is dim when Undo is not available.

Creating a Drawing
For practice, work through this section to create the following
simple floor plan.

1. Highlight the wall tool. Move the pointer onto the wall tool
and click once to activate it for use.
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2. Draw the first wall of the room. Refer to the following
illustrations. Move the pointer into the top left corner of the
drawing area, hold down the mouse button and drag a wall
horizontally 20'. Note that you can hold down the shift key
while drawing to help draw straight walls.

3. Draw the right wall of the room. Move the pointer to the
right end of the first wall, hold the mouse button, and drag a
wall downward 16'.

4. Duplicate these two walls. Choose the selector tool, which
is the top left tool on the tool bar. Click on the 20’ horizontal
wall. Choose Duplicate (or hold Command + D) from the Edit
menu. Repeat this procedure with the 16’ wall. Move your
walls so that they form a rectangle. When you’re done, your
drawing should look like this.
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5. Open a furniture symbol library. Select Open Library
Window under the Symbols menu. Find and Open the Symbol
Libraries folder, then find the Seating library and double-click
its name. Your drawing window shrinks, if needed, to make
room for the library window, which opens along the right side
of the screen (as illustrated in step 6).
6. Create a 3D view. This is a good time to open a 3D view of
the drawing, which you can use for reference as you place
furniture. Click the button named "3D" located below the
drawing tools.

In the 3D window, click on the birds-eye view button represented by the flying bird. The bottom of the drawing window
shrinks, if needed, to make room for the 3D window, which
opens beneath it as in the following illustration.

7. Place a sofa in the room. Click the library window to bring
it to the front. Select the red sofa named "7' Sofa 1A". From the
Symbols Menu, select 3D Preview. You should see the following graphic.
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Close the 3D Preview window and select the red sofa again.
Hold down the mouse button and drag the sofa into the room.
Position it near the top wall. Notice the sofa appears in the 3D
view as well.

Note: If needed, use the library window's scroll bars or it's
grabber tool (hand icon) to scroll symbols into view and access
them. If you use the grabber, don't forget to click the selector
tool (the arrow) afterwards so you can continue to drag and
drop symbols into your drawing.
8. Place a chair in the room. Click the library window, use
the scroll bars as needed to find the red chair named "Seat 1A"
and drag it into the room along the left wall. Press the "<" key,
or select Rotate Left under the Arrange menu to rotate the
chair. Move onto it and drag it into position.

9. Place the remaining furniture in the room. Using the
same techniques described in steps 5, 7, and 8, add the remaining furniture into the room as listed.
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Seating library:
Seat 3A; press ">" to rotate right
Open Table library:
Coffee tbl 1C
End tbl 1C
Duplicate the End tbl by pressing command-D
Open Lamps library:
Tbl lamp 1B; place on End table
Duplicate the Tbl lamp; press command-D
10. Select the Window Tool
Click on the left wall above the seat to place your window.
Notice the smart window feature which positions the window
correctly within the wall. Click on the Selector Tool. Press and
hold Command + 1 to show the window dialog as seen below.

Change the 3D Height to 5’ and the Width to 3’ and click Ok.
Notice the size of the window in the 3D Window has changed.
11. Select the Door Tool
Click on the right portion of the bottom wall to place your
door. Again, notice the smart door feature, which places your
door correctly. Click on the Selector Tool. Press and hold
Command + 2 to show the door properties dialog as seen
below.
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Change the Width to 2’6” and click Ok. Notice the width of the
door in the 3D Window has changed. Let’s change the direction that the door opens. You will see four small arrows inside
the door you placed. Click on the top arrow to change the door
to open inward.
Your layout should now appear as seen below.

12. Select the floor tool. Click the floor tool.

13. Create a floor. Though a default square floor appears
automatically in 3D under an entire floorplan if no floor object
exists, you’ll most likely want to use the floor tool to create
individual floors for each room. Use the walls as a guideline to
draw a floor. The floor consists of a polygon. Therefore, the
23
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floor tool works like a polygon tool. Though this sample room
is square, you can also create floors of any shape.
To begin, move to the top-left corner of the room where the
walls meet and click (press and release the mouse button).
Moving clockwise, click at each corner of the room until you
return to the starting point (draw corner-to-corner, across the
entryway at the bottom). Note that you can also double-click at
any time to end the drawing.
14. Add an auto-roof to your structure.
Click on the Auto-Roof Tool.
You will see a roof automatically placed on top of your structure. This tool is useful if you want to create a roof quickly.
Instead, for purpose of illustration, lets create a different roof.
Click on the Remove Auto-Roof Tool.
You will see the Auto-Roof disappear.
15. Add a roof object to your structure.
Double-click on the Roof-Object Tool.
This will bring up the Roof-Object Dialog. This dialog allows
you to change the roof object properties and preview the roof
object. Click Ok to return to your drawing.

Now let’s actually place a roof object. Click and drag with the
Roof-Object Tool from a point above and to the left of the
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structure to a point below the bottom right corner of your
structure. Doing this will give the roof a little bit of overhang.
If the roof is not correctly centered, choose the selector tool
and center the roof. In the 3D Window, click on the Front View
button, located to the right of the Birds-Eye View button.

You will notice that there is a gap between the top of the walls
and the new roof object in the 3D Window. To correct this,
select “Wall Tool” from the Layout Menu. Click in the box
next to “Auto Extend Walls Up To Ceilings” and click Ok. The
tops of the walls should now extend to the roof object.

The sample room layout is now finished.

This simple example demonstrates only a small part of what
3D WalkAround can do. Read through the rest of the manual to
learn more. And, if you want, continue to the next section and
take a virtual walk in your newly created room.
25
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Going For A 3D Walk-Around
The easiest way to learn how to perform a 3D walk-around is
to simply experiment and try it out. For this purpose, we’ll use
the sample room created in the previous section. However, if
you didn’t work through the previous section, go ahead and
open one of the sample layouts instead.
If you worked through the previous section, you already have a
3D window open. If not, click the 3D button to open a 3D view
of your design.

For the sample room, you should see the following (note that
for purpose of illustration, we aren’t showing the ceiling here).

When the 3D window first opens, the bird’s-eye (or overhead)
view is shown. Move the pointer into the 3D window, hold
down the mouse button and experiment moving (or flying) left,
right, up, and down. The further from the center of the window
you are, the faster you move. You can also move using the
keyboard arrows or the movement buttons (the arrow tool icons
along the left side of the window).
Click the bottom (or north facing) walk-around side view
button, as indicated with a camera symbol and an arrow pointing up.
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This changes the 3D view to a walk-around side view. This and
the other side view buttons look at the 2D layout in 3D from
the direction indicated by the arrows on the buttons. The
rightmost button resets the camera to its previous position.
Now, go ahead and experiment moving again. Up/Down mouse
movements move inward and outward, and left/right movements move left and right (hold shift to turn left and right
instead). Here’s how it looks when you move into the room.

Feel free to go ahead and experiment with all the 3D window
buttons. You can’t hurt anything. Refer to the “3D Tools”
section of the “Tools” chapter for a more detailed description
of all the 3D window’s buttons, and for more about how you
can use modifier keys to alter movements.

Setting 2D/3D Object Altitudes & Heights
The altitude box (or edit field) at the left side of the bottom
scroll bar lets you specify the height above the floor for selected 2D objects such as table lamps, hanging lights, and so
on.
The specified altitude is used when placing objects in the 3D
view. If the 3D window is open when you change object
altitudes, the objects are automatically adjusted in the 3D view.
To specify or change object altitudes:
1. Click the selector tool and select one or more objects.
27
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2. Type an altitude. Click the altitude box and type an altitude
(e.g., 2’, 30”, 3.5 are all valid altitudes). Press return or click
anywhere to apply the altitude to all selected objects.
The height box (or edit field) at the left side of the bottom
scroll bar lets you specify the height of selected 2D objects.
This feature is used to change the vertical size of 3D objects.
Once an object has been resized in 2D, use this option if desired to independently change a 3D object’s height.

Setting 3D Textures and Object Info
To specify textures for walls, floors, and other symbols that
appear in the 3D view, first select their 2D counterparts, then
choose Set Object 3D Info under the Edit menu.

Texture Categories. Click the desired texture category.
3D Textures. Click a texture and the Apply Texture button, or
double-click a texture, to apply it to the currently chosen 2D
object (shown in the 2D Selection box, explained below).
Walls and floors can have two textures, one for each side of a
wall, and one for the top and bottom of floors. Command-doubleclick a texture, or click it once and click the Side2 Texture button
28
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to apply textures to the second side of walls or the bottom of
floors. Note that for walls, the 2D Selection box indicates which
side is side one and which is side two.
An easy way to create additional library symbol variations is to
duplicate the desired 2D library symbol, select it, and bring up
this 3D settings dialog. Then assign the texture of your choice
to the symbol, leaving the other data unchanged. You’ll almost
certainly want to customize floors and walls with your own
texture choices. The newly applied textures show up in the 3D
view when you exit the dialog, if the 3D window is open.
Otherwise, they appear when the 3D window is next opened.
You can save your changed symbols to a library using the
Library feature under the Symbols menu.
2D Selection. This box shows the currently chosen 2D object.
Textures and the other 3D data apply to this object. If more
than one 2D object was selected with the selector tool prior to
displaying the dialog, you can cycle through the selected
objects using the “<<“ and “>>” buttons.
Description. Use this field to specify a name or description for
the object.
Image Filename. This specifies the 3D image file to show in
the 3D view for the 2D object in the 2D Selection box. Since
these images have already been assigned to all the library
symbols, it’s not likely you’ll need to change them, but the
capability is provided. The 3D symbols are in the Images3D
folder.
Apply Texture, Side2 Texture. Please refer to “3D Textures”
above for a description of these buttons.
Texture Scaling. These settings let you to change the scale at
which textures are displayed on 3D walls and floors.
Revert Info. This changes all the 3D settings back to their
original settings prior to the most recent changes.
29
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Delete Info. This deletes all the 3D info for the currently chosen
2D object. In this case, nothing will appear in the 3D window for
the object.

Using Patterns
3D WalkAround provides a pattern palette with many different
patterns you can use in your designs. And as you'll see later,
you can also edit the patterns if desired.
You can use the patterns for both filling object interiors and for
drawing lines and object borders. The pattern used for object
borders, and for drawing lines, is referred to as the line, or pen,
pattern.
The not-equal, , symbol at the top left corner of the palette
(see the preceding illustration) tells 3D WalkAround not to use
any pattern. Using it as a line pattern lets you create objects
that have no borders. Using it as a fill pattern lets you create
objects with transparent interiors. Here are some examples of
objects drawn with various pattern combinations:

Notice in the preceding illustration that the textured circle in
the background has no border. The not-equal symbol was used
as its line pattern. Similarly, you can see through both the arc
and the rectangle that’s in front of the circle. The not-equal
symbol was used as the fill pattern in this case. Also demonstrated is the use of line patterns to draw dotted and dashed
lines. Here are some patterns you may find useful for that
purpose:
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The two reference boxes at the left end of the pattern palette
show the current working line thickness, working line pattern,
and working fill pattern.

The currently highlighted box, which is darker and outlined in
red, indicates which type of pattern is affected by clicks on
patterns in the palette, the line pattern or the fill pattern. Click a
pattern when the right-most box is highlighted, and the working fill pattern is changed, as well as any selected objects’ fill
patterns. Similarly, if the left-most box is highlighted, the
working line pattern and any selected objects’ line patterns are
changed. To change which type of patterns are affected, simply
click the desired reference box. You’ll see step-by-step how to
use these shortly.
The line pattern reference box also shows what the current line
thickness is. You set the line thickness by choosing a size from
the Line menu, or by pressing a number (1-8) on the keyboard.
Here’s how the reference boxes look when the line width is
changed to 3 dots thick and a textured fill pattern is clicked:

And here are some example objects drawn with the preceding
settings:

As the illustration demonstrates, when you draw with the
standard drawing tools, the final object you create takes on the
working line thickness, line pattern, and fill pattern that’s
31
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shown in the two reference boxes (note that some tools' defaults are set under the Text and Layout menus).
You can change the line thickness, line pattern, or fill pattern
of existing objects by selecting the objects and clicking the
desired pattern, or by choosing a new line size.
Changing Objects’ Patterns
Here’s how to change existing objects’ patterns.
To change fill patterns:
1. Click the selector tool, then click the fill pattern reference box.
2. Select the object that you want to change. Click the object
that you want changed to a different fill pattern to select it. You
can also change more than one object at once (see “Selecting
Objects” if you need more help). As an example, we’ll change
a rectangle and a couch. Here’s how they look initially:

3. Click the fill pattern you want to use. Try clicking various
patterns until you find one you like. Here’s an example:

Notice that all selected objects take on the clicked pattern.
Now we’ll use the preceding example again to demonstrate
how to change line patterns.
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To change line patterns:
1. Activate the selector tool, then click the line pattern
reference box.
2. Select the object that you want to change. We’ll use the
same example again, except this time, we’ll change the line
pattern.
3. Click the line pattern you want to use. Try clicking various patterns until you find one you like. Here’s an example:

Here’s an example of clicking not-equal to remove object
borders:

Changing Grouped Objects’ Patterns
Please see “Group” in the “Menus” chapter for more information about grouping objects.
Changing the patterns for grouped objects can be slightly more
involved, depending on what object within the group needs
changing. Once an object is grouped, 3D WalkAround treats all
its component objects as a single object unit. This means that if
you select a grouped object as described above and click a
pattern, all components of the grouped object take on the
pattern.
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At times, you may only want to change an individual component object and not all objects within the group. To do this, you
must first temporarily ungroup the object. To do so, simply
select the grouped object and choose Ungroup from the Arrange menu. Click a blank area to unselect all the objects.
Select the component object that you want to change and
follow the same procedures described earlier for changing
patterns. When done, select all the component objects and
regroup them by selecting Group from the Arrange menu.

Editing Patterns
Though 3D WalkAround comes with a variety of ready-made
patterns, you may occasionally want or need a pattern that’s
not available among the provided patterns. For this reason, 3D
WalkAround lets you edit the existing patterns.
To edit a pattern, choose Edit Patterns under the Edit Menu. A
dialog appears for editing the patterns.

Move onto the pattern palette in the dialog, and click the
pattern you want to edit. The selected pattern displays at an
enlarged size in the edit box on the left, and at it’s normal size
in the reference box on the right. Move into the enlarged, edit
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box area and click (or drag) to edit the pattern. Clicking a white
area changes it to black, and clicking a black area changes it to
white.
A description of the dialog buttons follows.
Fill White. Click to quickly erase, or set to white, the entire
edit box.
Fill Black. Click to quickly set the entire edit box to black.
Undo. Click to reverse the last change made to an edited
pattern.
Temporary. Click Temporary to exit the edit dialog and
continue using the edited patterns during the current work
session. However, when you quit 3D WalkAround, the edited
patterns are discarded (use Save to keep them permanently).
Any objects within a drawing that used any discarded patterns
retain their correct patterns, since an object’s pattern is kept
independently with the object. Therefore, you might want to
use Temporary to experiment with patterns, or to create unique
patterns for immediate use, and not permanently alter the
existing pattern palette (which is restored automatically the
next time you start 3D WalkAround).
Cancel. Choose Cancel to exit the dialog and discard all
changes made to the pattern palette since selecting Edit Patterns.
Save. Click Save to exit the dialog and retain all pattern
changes. The patterns are saved and available even after quitting and restarting 3D WalkAround. However, should you
desire to at some later time, you can choose Default Patterns
from the Edit Menu to replace the changed patterns with those
that were originally provided with 3D WalkAround.
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Using Colors
This section primarily describes the use of color as it relates to
creating 2D floorplans, however, you can also use the color
dialog described here to set the background color of the 3D
window when it is the front/active window.
The Color menu lets you choose foreground and background
colors for fill patterns and line, or pen, patterns. Note that the
terms pen pattern and line pattern refer to the same thing, the
pattern that’s used to draw lines or object’s borders. The Show
Colors menu item lets you show a floating dialog for choosing
colors, or you can choose any of the standard old-style
Quickdraw colors directly from the Color menu. You might
prefer using the menus for quickly setting colors to black,
white, or any of the standard colors.

Choosing Show Colors from the Color menu causes the following floating dialog to display.
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You can choose and edit colors from the color wheel dialog or
from a color palette. Choose which by clicking the desired
option.
Color Wheel
To use the color wheel, click the buttons for the color type (fill
vs. pen, etc.). This is explained further later. Move onto the
color wheel and click to choose a color, or drag the small
circular selection bead. The chosen color displays near the top
of the dialog. The brightness bar on the right side of the dialog
lets you change a color’s brightness (or darkness). Click the
desired brightness bar location, or drag the thin horizontal
selection bar upward or downward to the brightness you want.
Each time you click a wheel color, the brightness bar is set to
white. Hold the command key when selecting colors to retain
the brightness setting.
Note: When holding command down, if the brightness bar is
set to completely black, all colors you click on the wheel
appear black as well.
The color wheel is designed to provide a broad range of color
choices subject to the capabilities of your system. The wheel
works with 256 or more colors up to the 16+ million available
on some Macintosh systems that have 24-bit color. All possible
colors are obtainable using the wheel and brightness bar.
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Color Palette
Selecting the Palette button from the color dialog lets you
choose from a palette of 256 colors. To choose a color, set the
buttons for the color type (pen vs. fill, etc.), then move onto a
palette color and click.
Fill Versus Pen Colors
The Fill Foreground and Fill Background menu items and color
dialog buttons set colors for objects’ interior fill patterns. The
Pen Foreground and Pen Background items set colors for line
patterns and object border patterns. The currently selected
colors display near the top of the color dialog, and at the upper
left corner of the drawing window.
When 3D WalkAround draws colored objects, what would
normally have been black draws using the foreground colors,
and what would have been white draws using the background
colors. The following steps, which show how to change an
existing object’s colors, illustrate this more clearly.
Changing Objects’ Colors
To change the color of an existing object:
1. Activate the selector tool.
2. Select an object (or objects). We’ll use the following
object:

3. Set the object’s colors. Use the Color menu items or from
the color dialog, choose the desired colors according to the
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following illustration, which is an enlargement of the preceding
illustration’s top left corner.

By experimenting with various textured patterns and different
foreground and background color combinations, you can create
an even wider variety of color blends.
Using The Eyedropper Tool
Since the color dialog provides a wide range of color choices,
an eyedropper tool is provided so that you may easily continue
working with a previously used color or pattern, or transfer an
object’s colors or patterns to other objects.
To set the current working colors or patterns to those of an
existing object:
1. Click the eyedropper tool.

2. Move onto an object and click or option-click. Move onto
an object whose colors you want to work with again, and click
to set the working colors to the object’s colors. Or, deselect all
objects (click a blank area), then hold the option key down and
click an object to set the working patterns to the object’s
patterns. The drawing tools use the new working colors or
patterns the next time you draw.
You can also use the eyedropper tool to have one or more
objects take on another object’s colors or patterns.
To transfer an object’s colors or patterns to other objects:
1. Click the eyedropper tool.
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2. Select the object, or objects, whose colors or patterns you
want to change. Click an object, or shift-click to select several
objects.
3. Command-click an object to transfer it’s colors or optionclick to transfer it’s patterns. You may use both command
and option at once if desired. The new colors or patterns also
become the current working colors/patterns.

Moving Objects
To move an object: Click the selector tool. Move onto it and hold
down the mouse button. A dotted outline of the object appears.
Drag the outline to a new location and release the button.

To move several objects at once: Select the objects (see
“Selecting Objects” for help with selecting). Move directly
over any one of them and drag the resulting outlines to a new
location.
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Nudging Objects
3D WalkAround also lets you fine-tune object positions by
using the arrow keys to move objects. Simply select the objects
you want to move, then press the desired arrow key, or use the
arrows immediately after drawing an object to fine-tune its
position.

Resizing Objects
To resize an object: Click the selector tool. Move onto the
object you want to resize and click to select it. Move onto one
of its handles and hold down the mouse button. Drag the
object’s outline (or enclosing box) inward or outward to a new
size.

Resize in other directions by dragging with a different handle.

Rotating Objects
3D WalkAround lets you easily rotate objects in 90 degree
increments, or you can use the rotate tool to rotate objects to
any angle. Another choice is the Rotate By Degrees menu item,
which lets you specify how many degrees to rotate an object.
To rotate an object 90 degrees: Click the selector tool, select
an object and choose Rotate Left under the Arrange menu. Or,
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press the “<“ keyboard character without using the command
or shift key.

Follow the same procedure to rotate an object 90 degrees to the
right, choosing Rotate Right (or pressing “>”) instead.
To rotate objects by a specific number of degrees: Click the
selector tool. Select one or more objects and choose Rotate By
Degrees from the Arrange menu.

Type the amount of rotation, 1-359 degrees (45 degrees is used
by default). A positive value causes objects to rotate to the left
(counter-clockwise). Precede the amount with a minus sign to
rotate clockwise. For example, -20 rotates selected objects 20
degrees to the right (clockwise). Click Rotate to initiate and
complete the rotation of selected objects.
To use the rotate tool:
1. Click the rotate tool.

2. Select the objects you want to rotate. Click an object, or
shift-click multiple objects. Note that the rotate tool works like
the selector tool for selecting and moving objects. See “Selecting Objects” if you need help.
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3. Drag from any one of the objects’ handles. Move onto an
object’s handles, hold down the mouse button and drag the
resulting outline to the desired angle. Release the mouse
button. All selected objects rotate to the chosen angle.

Erasing Objects
The selector tool lets you erase (delete) unwanted objects.
First, activate the selector tool.
To delete objects: Select the object (or objects) that you want
to remove and press the delete key, or choose Clear from the
Edit menu (for help with selecting, see “Selecting Objects”).

You can also choose Cut from the Edit menu to remove selected objects and have them placed in the clipboard. From
there, you can paste them back into the same window, or
activate another window to paste into. See the “Edit Menu”
section for more about cutting and pasting.
To reverse an accidental delete: Immediately select Undo
from the Edit menu. If you click elsewhere, or perform other
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operations, Undo may be unavailable, since it works only for
the last operation performed.
Erasing Parts Of Objects
3D WalkAround is an object-oriented drawing program. Unlike
a painting program, each thing you draw, whether a line, circle,
or rectangle, is a separate object based on coordinate locations.
This is an ideal environment for designing programs like 3D
WalkAround, which must scale drawings and maintain a scaled
relationship with real-world sizes. But since everything drawn
is an object based on coordinates, it isn’t possible to erase a
portion of a single object like a rectangle (by rubbing away or
cutting out a piece like in a paint program).
However, you can often simulate a partial erase by drawing on
top of the unwanted part of an object with another white object.
Or at other times, maybe you only need to resize an object. For
example, if a line is too long, rather than erase the part that’s
too long, you can grab its handle and size it down (see
"Resizing Objects" ).
To erase part of an object with a white object: First, click
white for both the fill pattern and the line pattern (see “Using
Patterns” if you need help). Click the desired tool and draw a
white object over the part of the object that you want to erase.

In the preceding illustration, portions of the original circle and
line were erased by drawing over them with a white oval,
rectangle, and line.
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Using Snap
As an aid to precise drawing, 3D WalkAround provides extensive grid and object snapping capabilities. While drawing, if
snap is turned on, when you move near a snap point, it acts like
a magnet, pulling the drawing location to it. You can specify
whether to snap to grid points, line ends, object corners, and
more. This is especially useful for drawing precise wall and
floor corners.
To specify or change snap settings, select Snap from the Layout menu. A settings dialog displays.

Snap sensitivity. Type a snap sensitivity range. If you move
within this pixel (or screen dot) distance from a snap point, the
snap occurs.
Snap options. Click the box beside an option to enable or
disable snapping for it. When you enable the “Snap to grid”
option, a dialog appears for choosing a grid spacing. Simply
click the desired spacing then click Ok. Please see “Measuring
And Using Reference Markers” in the tutorial chapter for
information about reference markers.
Cancel. Click this to exit the dialog and leave the settings
unchanged.
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Temporary. Click Temporary to use the settings during the
current drawing session only. The original settings are restored
when you quit and restart 3D WalkAround.
Save. Click this to use the settings and also save them for
future use. The settings are retained after quitting and restarting
3D WalkAround.
Measuring And Using Reference Markers
At times, you may want to know the size of an area or the distance
between two points, or you might want to mark a location for
future reference as an aid in positioning, drawing, and aligning
objects. The measure tool lets you accomplish all this, and more.
To specify or change settings for the measure tool, select
Measure Tool from the Layout menu, or click the tool icon
after it is already highlighted. The settings dialog displays.

Measuring Method. Click Rectangular to show the width,
height, and area of an enclosed, rectangular area. Click Line to
show length and angle information. You can hold down the
option key to temporarily switch to the opposite setting while
using the measure tool.
Reference Markers. If “Create reference markers” is enabled,
when you measure a rectangular area or linear distance (you
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measure an area by dragging, like with the drawing tools), the
measure tool leaves a reference marker after the mouse button
is released. The marker style and marker color options control
the reference marker’s appearance. If you enable the “Delete
markers upon exiting this dialog” option, then all existing
reference markers in the active drawing are deleted (you may
also use the selector tool to select, move, and delete individual
markers).
Cancel. Click this to exit the dialog and leave the settings unchanged.
Temporary. Click Temporary to use the settings during the
current drawing session only. The original settings are restored
when you quit and restart 3D WalkAround.
Save. Click this to use the settings and also save them for future
use. The settings are retained after quitting and restarting 3D
WalkAround.
To measure an area:
1. Click the measure tool.

2. Specify the measure tool settings. If you want to change
the current measure tool settings, click the measure tool icon a
second time to bring up the settings dialog, then specify the
desired settings as described earlier.
3. Move to the start position and drag. According to the
current settings, line or rectangular measurements are shown
while dragging. Hold the option key to dynamically switch
between the type of measurements. If “Create reference markers” is enabled, when the mouse button is released, a reference
marker is created at the drag location according to the current
style and color settings. Hold the command key to temporarily
switch to the opposite “Create reference markers” setting and
leave, or not leave, a reference marker. If a reference marker is
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created that isn’t wanted, select Undo or use the selector tool to
delete it.

Editing Existing Text
You can use the procedures described here to change any type
of text object. First, you’ll see how to edit the actual text of an
object, then you’ll be shown how to change its font, size, or
style. See the “Tools” chapter for more about the text tool.
To edit an existing text object:
1. Activate the text tool. You use the text tool to edit existing
text, or to type new text.

2. Click the text you want to edit. When using the text tool,
an I-Beam cursor displays when you move into a window’s
drawing area. Move the I-Beam cursor onto the text you want
to change and click (see the following illustration). This reactivates the text for editing. A blinking bar cursor, the insert
cursor, appears in the text at the position where you clicked the
I-Beam cursor.

3. Edit the text. Use the arrow keys to move the blinking insert
cursor within the text. Press the delete key to delete text, or
from the keyboard, type any additional text you may want.
What you type is inserted at the insert cursor’s position. In the
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preceding example, we used the right arrow to move between
the “y” and the apostrophe, pressed the delete key, then typed
“Linda” to end up with the following:

4. Click another tool or new location when done. When
finished, click another tool to stop editing text and use the
clicked tool, or click another location in the window to start
typing new text.
To change existing text’s font, size, or style:
1. Click the selector tool.
2. Click the text object you want to change. Move onto the
text object that you want to change and click to select it.
Handles should appear at its corners.

3. Select the desired item from the Text menu. Choose a new
font, size, or style from the Text menu. While the text is selected, continue choosing additional menu items as desired
(you can also choose one of the line spacing menu items for a
text object that has multiple lines of text). The selected text
changes according to the chosen menu item(s).
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We changed the previous example’s font from Plain to
Shadow, which resulted in this:

For additional information about the text tool, see the “Tools”
chapter. For more about the Text menu items, see the “Menus”
chapter.
Zooming In And Out
3D WalkAround lets you zoom a drawing in to magnify it, or
zoom it out to reduce it. Zooming in provides a greater degree
of control and precision for fine-tuning positions and object
sizes. Zooming out lets you see and work with more of a
drawing at one time (you can also see an instant overview of
your entire drawing by selecting Overview from the Layout
menu).

The zoom controls are located at the lower left corner of a
drawing window.

You can control the focus of the zoom by selecting an object
first. Zooming then occurs based the selected object’s location,
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otherwise, zooming is based on the upper left corner of the
window.
Using Multiple Layers
You may occasionally find it useful to keep portions of your
drawing, such as walls, floors, wiring or plumbing diagrams,
rooms, or levels separate from other parts. 3D WalkAround’s
multiple layer support lets you easily accomplish this.
You can create, edit and view objects on a single layer, a
combination of layers, or on all layers at once. And though it’s
easy to create and use multiple layers, it isn’t required. Most of
your drawings may only need the single default layer, Layer 1.
The choice of whether to use additional layers is yours.
You’ll find layer controls located near the lower left side of the
drawing window.

The layers dialog lets you create, delete, and manipulate layers.
To access the dialog, click “Layer” (see previous illustration),
or select Layer from the Layout menu.
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Initially the default layer, Layer 1, appears in the “Layer
Name” list. Click New to add a new layer to the list. In preceding illustration, Layer 2 was added by clicking New.
Active layer. The active layer is the layer in the list that’s
preceded by a check mark. It’s also the layer that is active for
drawing and editing objects once you exit the dialog. Click in
the column next to a layer name to make it the active layer.
Also, when you cycle through visible layers using the layer
controls shown earlier, you are changing the active layer. Only
one layer may be active at a time.
Selected layer. The selected layer is the layer in the list that is
highlighted. You need to select a layer to manipulate it (for
example, to delete, hide, show, or name it).
Layer names. The names of existing layers appear in the
“Layer Name” list. When a layer is created, the default name is
“Layer” followed by a number. However, you can change layer
names by selecting a name from the list, and typing a new
name in the provided “Name:” box. When drawing, the active
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layer’s name follows the document name at the top of the
drawing window.

Changing the layer stacking order. Move onto a layer name
in the list, and drag to rearrange the stacking order of layers.
Objects in the drawing window are displayed from the topmost layer (first in the list) to the bottom-most layer (last in the
list).
New. Click New to add a new layer to the list (and your drawing). Afterwards, if desired, type a new name for the layer, or
set other options.
Delete. To permanently remove a layer (and all objects it
contains), click the desired layer name then click Delete.
Show. To make a layer visible (it must be visible to work with
it and see it’s objects), select the layer name then click Show.
New layers are defaulted to visible.
Hide. Click Hide to temporarily not display objects on a layer.
You cannot see or work with objects on a hidden layer. Use
Show to make the layer visible again. Layer names (in the list)
are dimmed to indicate they are hidden. Note that objects on
hidden layers don't appear in the 3D view.
Cancel. Click Cancel to exit the layers dialog and reverse all
layer changes.
Ok. Click Ok to exit the layers dialog and retain all layer
changes.
Inactive layer options. For each layer, you can specify
whether to allow object selecting (with the selector tool) or
whether to show objects dimmed (outlined) when the layer
isn’t the active layer. Normally, you probably won’t need to
select or edit objects on layers you aren’t working with, so the
“Allow selecting...” option is disabled by default. If the “Out53
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line objects...” option is disabled, objects are drawn normally,
otherwise, only a dim outline appears. This lets you more
easily determine which objects are on (or are not on) the
currently active layer.
These options are mutually exclusive. Objects need to be
displayed normally in order to select and edit them. However,
you can disable both options at once if desired. Also, note that
layers must be visible (not hidden with Hide) for these options
to take effect.
Layer display options. You may choose to show all visible
layers, or only layers which appear beneath the currently active
layer. For example, if you had 3 layers and the active layer was
layer 2, then if you enabled the option “Show layers below the
active layer only”, only layers 2 and 3 would display. By
default, all visible layers are shown so you can more intuitively
hide specific layers using the Hide button. However, the flexibility to automatically hide higher-ordered layers is also
available if needed.
Using New Layers
After creating new layers, they are empty until you draw or
copy objects to them. To use a new layer, simply make it the
active layer (using the layer controls or from the layers dialog),
then begin drawing. To verify which layer is currently active,
glance at the layer name that’s shown in the window’s title bar
following the drawing name.
You can also copy objects between drawings and between
layers. To do so, activate the window and/or layer containing
the objects, select the objects and choose Copy, then activate
the destination window and/or layer, and choose Paste.
In some cases, you may find it useful to dim inactive layers to
use as a guideline for drawing on other layers. For example,
you may want to see a floor plan’s walls while creating a
54

Chapter 2, Tutorial
plumbing diagram or while placing furniture symbols on a
different layer. Remember that you can change the front-toback (or top-to-bottom) order of the layers if needed, as described earlier.

Creating Your Own Symbol Libraries
If you need to, you can create your own custom symbols, or
other objects, then save them to a new or existing symbol
library for use later, whenever they are needed.
Here’s an overview of the process. Use the drawing tools to
create the symbols in a new empty window, select the symbols,
then select Library from the Symbols menu. To use the symbols, select Library, choose a symbol, then click Paste.
As a learning exercise, let’s work through the steps for creating
this ceiling fan symbol, which really consists of three separate
objects:

To make the example symbol:
1. Open an empty, untitled window to work in. If you
already have an empty, untitled window open, skip to step 2.
Otherwise, select New from the File menu to open an empty
window.
2. Click the rounded rectangle tool to activate it for use.

3. Move into the window and draw the symbol. The following illustration shows the drawing sequence. It’s not important
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that your symbol look exactly like the one shown here, since
this is only for demonstration purposes.

After drawing the object, if you don’t like the result, you can
select Undo from the Edit menu and try again. Our sample is 5"
by 5' in size.
4. Create a second fan blade. Activate the selector tool. The
object should automatically select, since it’s the last object you
drew. Select Duplicate from the Edit menu, rotate the duplicate
to the right by choosing Rotate Right from the Arrange menu,
then position the duplicate on the first object as shown.

5. Draw a circle to represent the light fixture. Click the oval
tool and change the fill pattern to black by clicking the black
pattern on the pattern palette. Draw an 8" by 8" circle. Then
click the selector tool and position the circle as shown.
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6. Group the objects. Refer to the following illustrations. Drag
a selection box around the objects, then choose Group from the
Arrange menu. The ceiling fan is now completed.

7. Save the symbol to a library. Choose Library from the
Symbol menu, then either choose a library from the Library list
(to save the symbol to an existing library), or choose New
Library (to create a new library for your symbol). Click the
Add button. Type “ceiling fan” for the name, then click Ok to
copy the symbol into the library. See “Using Symbol Libraries”
for more about the Library dialog.
Note: The preceding process is for creating 2D symbols. For a
2D symbol to appear in the 3D view, you must also specify a
3D image file for it (i.e., link it to an actual 3D symbol). Please
refer to "Setting 3D Textures And Object Info" in the menus
chapter for more. Also note that for 3D-linked symbols, the 3D
Info should be specified before the symbol is saved to a library
in step 7.
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You can follow the same general procedure above to create as
many symbols as you want in the same library, or save related
groups of symbols in other libraries if you prefer.

Using Symbol Libraries
3D WalkAround provides extensive symbol library support.
You can access symbols one of two ways, either by opening a
library as a window, or by selecting Library from the Symbols
menu.
To drag and drop library symbols into a design, choose Open
Library Window from the Symbols menu. A file dialog appears. Move to the Symbol Libraries folder, then double-click
the desired symbol library. A window opens displaying the
library's symbols. Use the windows's scroll bars or the grabber
tool as needed to scroll symbols into view. To add symbols to
your design, click the selector tool, select one or more symbols,
and drag them to your drawing window.
Select Library from the Symbols menu both to access symbols,
or to edit or create your own symbol libraries. After selecting
Library, a dialog appears.
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Note: More libraries are available than initially appear in the
library list. Please see "Open Library" below for how to access
them.
A description of all the Library options follows.
Library list. A list of the working libraries. To work with a
particular library, click its name in the list.
Symbol Name list. A list of the symbols in the currently
selected library (from the library list). Click a symbol name,
and its image appears in the Symbol box on the top right.
Symbol box. Shows the currently selected (highlighted) symbol from the Symbol Name list.
Selection box. If you use the selector tool to select objects
before choosing the Library menu item, you can cycle through
and view them in the Selection box, or add them to the working
Library (see “<< Add <<“, “<<“, and “>>” below).
Paste. Click Paste, or double-click a symbol name, to paste a
symbol into your drawing and exit the Library dialog.
Delete. Click Delete to remove the currently selected symbol
from a library.
Rename. Use Rename to change a symbol’s name.
<< Add <<. Click Add to copy the selected object shown in the
Selection box into the currently selected library. A dialog
appears for naming the object.
Exit. Click this to exit the library dialog without pasting an
object into your drawing.
<<. Click this button to move backward through selected
objects.
>>. Click this to move forward through selected objects.
New Library. Click this button to create a new empty library file.
After selecting New Library, a file dialog appears. You’ll probably
want to create the library inside the Symbol Libraries folder. To do
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so, open the Symbol Libraries folder from within the file dialog,
then type a name for your new library and click Save. The name is
added to the Library list. Now you can add selected objects to the
library (see “Selection box” and “<< Add <<“ above).
Open Library. This lets you open an existing symbol library
and add its name to the list of working libraries. You need to
open a symbol library file before you can access its symbols.
After selecting Open Library, a file dialog appears. Move to the
Symbol Libraries folder to find the provided symbol libraries,
and double-click the desired library name. You may work with
up to 10 libraries at once.
Close Library. Select a library name and click Close Library
to remove it from the list of working libraries. Click Open
Library to add the name back into the working library list when
desired. Close Library doesn’t delete the library from disk. To
delete a library file from your disk, first close it with Close
Library, then use the Finder to drag the library file to the trash
can.
Important: If you edit existing libraries, or create your own,
it's a good idea to make a back-up copy of the Symbol Libraries folder to use for restoring your originals should they ever
become damaged.
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Tools
The tool palette is located along the left side of the drawing window.

Selector
Rotate

Grabber
Eyedropper

Measure

Shaper

Line
Hollow Line
Rectangle
Oval
Polygon
Stud Tool
Multigon
Status
Door Tool
Roof-Object Tool
Auto-Roof Tool

Constrained Line
Wall
Rounded Rectangle
Arc
Sketched Area
Bezier
Text
Floor/Ceiling
Window Tool
Camera
Remove Auto-Roof

To select a tool, move onto it and click. The currently
selected tool is highlighted (darkened and outlined in
red), which indicates it’s activated for use.

62

Chapter 3, Tools

Selector Tool
Many of 3D WalkAround’s features let you manipulate
existing objects. You can copy objects, resize them, move
them, rotate them, and much more. But for these features
to work, they need to know which object, or objects, you
want to change. That’s where the selector tool comes in.
Selecting objects using the selector tool lets other features
know which objects you want to change.
Selecting Objects
To select objects, you need to activate the selector tool.

Handles. Small squares, called handles, indicate an object
is selected. Here are some examples of selected objects:

Before showing you how to select objects, you need to
know the difference between filled and unfilled objects.
An object which has a white interior is still considered a
filled object if the white pattern was used as its fill pattern. An unfilled object is one that was created using the
not-equal symbol as its fill pattern (for more about patterns, see “Using Patterns” in the tutorial chapter).

Unfilled objects have no interior fill pattern at all, which
means you can see through them. Here are some examples of both filled and unfilled objects.
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Notice that the circle on the left is beneath an unfilled arc
and an unfilled rectangle. You can see the circle through
the interior of the arc and rectangle. The circle on the
right has a white fill pattern, so you can’t see the rounded
rectangle through its interior.
To select a filled object: Move onto a visible part of the
object and click.
To select an unfilled object: Click its visible borders. For
example, to select the unfilled arc and the unfilled rectangle shown in the earlier illustration, move onto their
borders and click. If you clicked inside the rectangle on
top of the circle, you would select the circle instead of the
rectangle.
To select small objects, thin lines, or closely-spaced
objects: These objects are sometimes slightly more difficult to select. It helps to remember that the tip of the
arrow pointer is the active part of the arrow that’s used
for selecting. So when selecting small or closely-spaced
objects, carefully place the tip of the arrow exactly on the
object and click. If handles appear on an object other than
the one you want, click an empty, blank area inside the
drawing to unselect all objects, then try again. Sometimes, you may find it easier to select small objects by
dragging the selection box onto them. This is described a
little later.
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To unselect objects: Click any blank screen area inside
the drawing window, or click an unselected object to
select it and unselect all others.
Selecting Multiple Objects
To select additional objects:

To unselect an object:

You can also select objects by dragging a selection box
over them. Any object touched by the box is selected.
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Choose Select All from the Edit menu to select all the
objects in a drawing. You might want to do this sometime to adjust the position of (move) the entire drawing
within the drawing window (see “Moving Objects”).

Grabber Tool
This tool lets you grab and move your drawing within the
drawing window.
To use the grabber tool, click the tool’s icon to activate it
for use, move anywhere within the drawing area, hold
the mouse button, then drag the drawing within the
window. Note that this doesn’t move the objects on the
drawing page, it only moves the page within the window
(like the scroll bars).

Rotate Tool
Please see “Rotating Objects” in the tutorial chapter for
detailed instructions for using this tool.

Eyedropper Tool
Please see "Using the Eyedropper Tool" in the "Using
Colors" section of the tutorial chapter for how to use this
tool.

Measure Tool
Please see “Measuring And Using Reference Markers” in
the tutorial chapter for a detailed description of this tool.

Shaper Tool
The shaper tool works similar to the selector tool for
selecting and manipulating objects, except when selecting objects that have multiple vertices or control points,
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such as polygons and bezier curves, handles appear at all
the vertices and control points.
You can drag a handle to reshape the object, option-click a
handle to remove a vertex, or option-click a line segment
to add a vertex.
To reshape an object:
1. Click the shaper tool.
2. Click a polygon or bezier object and drag a handle.

To remove a vertex:
1. Click the shaper tool.
2. Select an object and option-click a handle. When the
option key is held down, the cursor changes to a knife for
cutting.

To insert a vertex:
1. Click the shaper tool.
2. Select an object and option-click a line segment.
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In some cases, you can take a short-cut to creating a more
complex object from another object primitive, such as a rectangle, oval, or arc by first converting it to a polygon (see
“Change To Polygon” in the “Menus” chapter).

Line Tools
The line, constrained line, and hollow line tools draw lines
between two points.
To draw a line: Click the desired tool, move to the start point
and hold down the mouse button. Drag to the desired end point,
then release the button. See the tutorial chapter for help with
setting line patterns.
The constrained line tool draws lines at perfect 45 or 90 degree
angles. You can also constrain other line tools by holding down
the shift key as you draw. Here are some sample constrained
lines.

The hollow line tool works like the line tools except when the line
thickness is greater than one, only an outline of the line appears.
Also, hollow lines can be filled with a pattern. Here are some
examples.
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Setting Line Thicknesses
The line thickness (or width) setting not only applies to the
width that’s used for lines, but also to the width used for other
objects’ borders. For example, here’s what you get if you draw
some objects with the line thickness set to 3 dots wide:

The line on the far right was drawn using the hollow line tool.
You can set the line width quickly by pressing a number (1-8)
on the keyboard, or you can choose a new size from the Line
menu.

The working line thickness is also shown in the line pattern
reference box.

Changing existing objects’ line widths. To change an existing
object’s line or border width, click the selector tool, then select
the object you want to change. Choose a width from the Line
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menu or press 1-8 to set a new width. The selected objects take
on the new width.
Using Dimension And Arrow Lines
You can also draw lines with an arrow on one end, on both
ends, or auto-dimensioning lines which have two arrows and
the length of the line placed at its center.
To draw an arrow line: Select the type of arrow line you want
from the Line menu (you can also press the number 9 to select
a dimension line). Click the line tool. Move to the line’s start
position and hold the mouse button down. Drag to the desired
size, then release the button.
Wall Tool
The wall tool lets you draw lines which represent the walls of a
floorplan, which automatically appear in the 3D view.
Draw walls in the same fashion as described for the line tools.
If desired, you can edit wall patterns and colors just like with
any other line. You can specify default wall tool settings by
selecting Wall Tool under the Layout menu, or by clicking the
tool icon after it is already highlighted for use.
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You can specify the thickness and 3D height of walls in pixels
(screen dots) or scaled measurements. The specified height is
used to generate the walls in the 3D view. Enter scaled
amounts as inches or feet-inches such as 7", 1’2", or 1.25.
Simply type the desired sizes.
You can create slanted walls by entering different values for
start and end points. The wall will slope proportionally between the two points.
Selecting the box next to “Auto Extend Walls Up To Ceiling”
raises the wall height up to the roof line automatically.
If you have Abracadata's Design Estimator product, you have
the ability to specify information for it as well. This is used
when you export an estimator file.
If you would like to have any of the settings applied to selected
wall objects, click the desired options indicating which settings
to apply. Otherwise, the changes apply only to the wall tool.
They are used the next time you use the wall tool.
You can specify 3D wall textures by choosing Set Object 3D Info
under the Edit menu. To create walls for multiple floor levels, you
can select walls with the selector tool and specify an altitude for
them in the altitude box at the left side of the bottom scroll bar.

Rectangle, Rounded Rectangle, And
Oval Tools
As their names imply, these tools draw rectangles (or squares),
rectangles with round corners, and ovals (or circles).
To draw using any of these tools: Click the desired tool, then
place the pointer where you want one edge of the object to
begin and hold down the mouse button. Drag the object to the
size you want, then release the button.
Constraining Rectangles And Ovals. Hold down the shift key
while drawing to constrain sizes to equal widths and heights.
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This lets you easily draw perfect circles and squares.
Please refer to “Using Patterns” in the tutorial chapter for
information about setting object patterns. See “Setting Line
Thicknesses” in the preceding section for information about
setting border thicknesses.

Arc Tool
Use the arc tool to draw arcs that are filled with patterns, or
arcs that are unfilled, consisting only of the arc lines.
To draw arcs: Click the arc tool, then move to the desired
position and hold down the mouse button. Drag downward if
you want the arc to represent the upper part of a circle or oval,
and drag upward for the bottom part of a circle or oval (see the
following illustration). Release the button.

Constraining Arcs. Hold down the shift key while drawing to
constrain arc sizes to equal widths and heights. This lets you
easily draw 90 degree arcs.
Polygon Tool
The polygon tool lets you draw a series of connected lines to
create a multiple-sided object. Here are some examples:

To draw a polygon: Click the polygon tool, then move to the
polygon's start point and click. Move to the first line’s end
point (and next line’s start) and click again. Continue this
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sequence until you’ve completed the object by ending at your
original start point, or double-click to end.
Constraining polygon line segments. Hold the shift key down
while drawing to constrain line segments to 45 and 90 degree
angles.
Please see “Setting Line Thicknesses” and “Using Patterns” for
information respective to setting these.

Sketch Tool
You can use the sketch tool when you need to create irregularly-shaped objects. Here are some sketched examples:

To sketch a region: Click the sketch tool, then move the
pointer to the start position, hold down the mouse button and
move the mouse. Release the button to stop drawing.
Please see “Setting Line Thicknesses” and “Using Patterns” for
detailed information about setting sketched area’s patterns and
line thicknesses.

Stud Tool
This tool is a terrific time saver when you need to draw a series
of rectangular objects like decks, fences, studs or rafters.
To draw with the Stud tool: Place the pointer where you want
to begin drawing. Hold down the mouse button, drag the object
to the size you want, then release the button.
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The area defined by the box becomes a single object filled with
studs.
To see information such as lumber estimates for a stud object,
select the object, then choose Info from the Edit menu.
Note: You can create a series of studs at other angles by
drawing a single rectangle/stud and using Multiple Duplicate
under the edit menu. Then, group all the objects and rotate to
the desired angle.

Bezier Tool
The bezier tool lets you create smooth, free-form curves.

A single bezier requires 4 points, a start point, an end point,
and 2 control points. While many implementations of this tool
limit you to single beziers, 3D WalkAround lets you create
multiple, linked beziers containing additional points. The
number of points needed for linked beziers is 3 times the
number of beziers plus 1 (e.g., 7, 10, etc.), since a previous
bezier’s last point is also the first point of the next bezier.
Though you should attempt to create beziers with the correct
number of points, the program automatically deletes extra
points should you miscalculate.
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To create a bezier curve:
1. Click the bezier tool.
2. Draw the points. The bezier tool draws like the polygon
tool. Move to a start position, click, drag to the next position
and click again. Continue to move to each point and click.
Move to the last position and double-click to end the curve.

If desired, you can move to more locations than shown here to
create more complex curves (as described earlier).
3. Reshape as needed. Click the shaper tool and drag the
handles to reshape the bezier as desired.

If desired, you can speed up redraws while reshaping by holding the shift key down. The points are temporarily linked with
lines, which draw faster. Please see the “Shaper Tool” section
for more about it.

Multigon Tool
You can use the multigon tool to create polygon-type objects with
a specified number of sides at a specified rotation. To change the
multigon tool settings, click the tool icon after it is already highlighted, or select Multigon Tool from the Layout menu.

75

Chapter 3, Tools

Type the number of sides you want, then type a rotation angle
(use zero if uncertain). You can specify from 3 to 45 sides. The
greater then number of sides, the closer the multigon resembles
a circle. The rotation angle lets you adjust the orientation of the
multigon. You can use it to control whether a vertex, or a side,
is positioned at the top.
To draw a multigon:
1. Click the multigon tool.
2. If desired, click the tool a second time to bring up the
settings dialog and change the settings.
3. Draw the multigon. Move to the desired start position, hold
down the mouse button and drag to the desired size. To create
regular polygons, hold the shift key down while dragging,
which constrains the size to an equal width and height.

The final object that’s created is a polygon, which can be
reshaped using the shaper tool, if desired.
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Text Tool
You can use the text tool to add names or other text labels to
your drawings, or to edit existing text. First, click the text tool
to activate it for use. Now, when you move into the drawing
area, an I-Beam pointer appears.

To add text to a drawing: Move the I-Beam pointer to the
spot where you want to begin typing and click. You’ll see a
flashing cursor appear. Go to the keyboard and type your text.
Press the delete key if you make a mistake, or press return to
end a line of text and start a new line below the previous line.
When you have finished typing, simply select a different tool.
The text you typed is converted into a single text object.
To type at a different location: If you want to continue typing
but at a different location, move the mouse to the new location
and click. The last text you typed is kept as an object and you
can begin typing a new text object as before.
To edit existing text: You can reactivate an existing text
object for further typing or editing by moving onto it and
clicking. See “Editing Existing Text” in the tutorial chapter for
more detailed instructions.
To edit using the mouse: Move onto the text, hold down the
mouse button and drag to highlight the desired text, then
release the button. Press the delete key or select Cut, Copy, or
Paste from the Edit menu. Pasted text is inserted where the
blinking cursor is located (or it replaces any currently highlighted text).
Manipulating Selected Text Objects
You can use the selector tool to select an existing text object,
then use items from the Text and Edit menus to operate on it.
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Items from the Edit menu operate on text objects just like they
operate on any other object. First, select the text object using
the selector tool, then select the desired item from the Edit
menu.
Text menu items let you set the size, style, type of font, justification, and line spacing for your text. Simply select the desired
menu item while typing text, or after selecting a text object
with the selector tool.
See the “Menus” chapter for more about the menu items, and
refer to “Editing Existing Text” in the tutorial chapter for
additional information about editing existing text objects.

Status Tool
This tool is provided for convenience. It displays a dialog
showing information about the active drawing window. It
performs the same function as selecting Status under the Apple
menu.

Floor/Ceiling Tool
The floor tool lets you draw polygons that represent floors or
ceilings, which automatically appear in the 3D view.
To draw floors, you'll most likely want to trace a room's walls.
Therefore, the floor tool works like the polygon tool so the
floor will align with walls more precisely.
To draw a floor: Click the floor tool, then move to the floor's
start point and click. Move to the first line’s end point (and
next line’s start) and click again. Continue this sequence until
you’ve completed the floor object by ending at your original
start point, or double-click to end.
Once a floor is drawn, it is automatically moved below walls
and other objects in the drawing. If desired, you can edit floor
patterns and colors just like with any other polygon. Similarly,
you can use the shaper tool to edit the shape of floors.
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You can specify default floor tool settings by selecting Floor
Tool under the Layout menu, or by clicking the tool icon after
it is already highlighted for use.
This tool can also be used to create ceilings. Accordingly, the
default texture that appears on the bottom of floors in the 3D
view is stucco (a ceiling texture). You can change the 3D floor
textures by selecting floors with the selector tool and choosing
Set Object 3D Info under the Edit menu (see “Setting 3D
Textures and Object Info in the tutorial chapter).
To create ceilings or floors at other levels, you can select floors
and specify an altitude for them in the altitude text field at the
bottom of the drawing window (see “Setting 2D/3D Object
Altitudes”). And, see “Creating a Drawing” in the tutorial
chapter for a hands-on demonstration of using the floor tool.

Door Tool
This tool allows you to place a door into your layout. To place
a door, click the door tool and then click inside any wall in
your design. This makes the door part of the wall, so even if
the wall is moved or resized, the door is adjusted accordingly.
You can only place a door within a wall.
Options for the Door Tool are available by double clicking the
Door Tool, or selecting “Door Tool” from the Layout Menu.
These options are discussed in Chapter 4.

Window Tool
This tool allows you to place a window into your layout. To
place a window, click the window tool and then click inside
any wall in your design. This makes the window part of the
wall, so even if the wall is moved or resized, the window is
adjusted accordingly. You can only place a window within a
wall.
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Options for the Window Tool are available by double clicking
the Window Tool, or selecting “Window Tool” from the
Layout Menu. These options are discussed in Chapter 4.

Roof-Object Tool
The Roof-Object Tool enables you to place a default roof
object on your existing structure. To place a roof object, click
and drag across your entire structure, encompassing the area
for the roof to cover.
Options for the Roof-Object Tool are available by double
clicking the Roof-Object Tool, or selecting “Roof-Object Tool”
from the Layout Menu.

Camera Tool
The Camera tool allows you to place camera(s) anywhere in
the plan view, which will enable you to view from specified
areas in the 3D Window.
Change Field or Depth of View

Move Camera
Rotate Camera
To move the camera, click and drag on the rectangle until the
camera is in the desired location.
To rotate the camera, click on the small crosshair beside the
camera and drag the camera to the desired angle.
To change the field or depth of view, click and drag the handle
on the outer edge of the camera to the desired position.
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Note that when you move the camera, your 3D view won’t
change until you release the mouse button.

Auto-Roof Tool
Selecting this option will allow you to place a basic roof
automatically. Once you have finished your structure, click this
button to have a roof automatically placed atop your walls.
Options for this tool can be changed by selecting “Auto Roof
Tool” from the Layout Menu.
Note that this tool is intended to quickly create basic roof
structures. If your floorplan is fairly complex, it could be
beyond the scope of what this tool can handle. In this case,
you’ll need to use the Roof-Object tool, or use the Floor/
Ceiling tool to create roof planes.
The Auto-Roof tool works best if you create the perimeter
walls of your floorplan as one continuous series of connected
walls, and don’t extend any perimeter walls into the interior of
a floorplan.

Remove Auto-Roof Tool
Clicking on this tool will delete any Auto-Roof object that has
been placed.

3D Walk-Around View Button
Click the 3D button to open a 3D window for the active 2D
design window. If needed, the bottom of the 2D design window
is sized down to make room for the 3D window, which displays beneath it. Please refer to the “3D Tools” section of this
chapter for a description of the 3D window tools.
Simply click the desired window to change between the 3D
window and the 2D layout window. You can adjust the posi-
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tions, orientations, textures, and altitudes of objects in the 2D
layout and the 3D window is automatically updated.

Layer Buttons
Click the Layer button to access the Layers dialog. Click the
up/down buttons to move the previous or next layer and make
it the currently active layer for editing or drawing. Please see
“Using Multiple Layers” in the tutorial chapter for detailed
information about the dialog and using layers.

Zoom Buttons
Click the zoom percentage button to toggle between 100% and
the last used zoom percentage. Click the “-” and “+” buttons to
zoom out and in. Please refer to the tutorial chapter for more
about zoom.

Altitude Box
Please see “Setting Object Altitudes & Heights” in the tutorial chapter.

Height Box
Please see “Setting Object Altitudes & Heights” in the tutorial chapter.

3D Tools
Bird’s-Eye View Button
Click this button to change from a walk-around side view to a
3D overhead bird’s-eye view of the 2D design, or to re-center
the overhead view. When you click the 3D button to open the
3D window, this is the default view. Please see “Going For A
3D Walk-Around” in the tutorial chapter for additional information.
82

Walk-Around Side View Buttons
Click these camera buttons to see one of four 3D side views, or
to re-center a side view. Please see “Going For A 3D WalkAround” in the tutorial chapter for additional information.
Light Intensity Buttons
Click the left-most button that has a down-arrow to lower the
light intensity and the button with an up-arrow to increase the
intensity. Click the center button to restore the default midrange light intensity. The right-most button toggles the lighting
between normal and slightly less reflective lighting.
Texture Buttons
Use these buttons to specify whether to apply textures to the
3D view. Click the left-most button for wireframe viewing,
which shows object outlines only. Click the center buttons to
show solid objects but without textures. Click the right-most
button for a solid, fully texture-mapped view.
Since texture mapping is slower, if you desire to increase the
walk-around speed, you can click one of the other options
temporarily and switch back to a texture mapped view when
desired. Of the three choices, the wireframe view displays most
quickly. Plus, since the wireframe view lets you see through
walls and objects, you might prefer to use this temporarily for
quickly moving to a desired location. Then, you can switch
back to fully textured viewing to see the details.
3D Zoom Buttons
Click these to zoom in or zoom out on the 3D view. On side
views, it may seem that you are walking in or out, however, the
camera is actually zooming and not changing positions. This is
more easily seen in the overhead (bird’s-eye) view. Click one of
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the walk-around view icons to re-center the view and set the zoom
level back to normal.

3D Movement Buttons

You can use the mouse or arrow keys for virtual 3D walkarounds, or you can use the movement control buttons to move.
First, general movement is described, then ways to modify
movement using modifier keys such as option, shift, and
control is provided.
To move using the mouse, move the pointer into the 3D window and hold the mouse button down. The further away from
the center of the window you are, the larger the steps and faster
the movement.
To move using the keyboard, hold down one of the arrow keys.
To move with the movement buttons, move onto the desired
button and hold down the mouse button. The top two buttons
move forward/backward on side views and fly laterally up/
down on the bird’s-eye view. The second row buttons step left/
right on side views (note that this can be toggled under Preferences to turn in place left/right instead) and fly left/right on the
bird’s-eye views. The third row buttons rotate left/right, and
the bottom two buttons tilt forward/backward.
You can use modifier keys to alter mouse and key movement
as follows:
shift: For left/right movements; turns in-place/rotates
control: For up/down movements, tilts
option: For up/down button and mouse movements, changes
altitude
Please see “Going For A 3D Walk-Around” in the tutorial
chapter for related information.
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Menus
As with virtually all Macintosh applications, you can access
many 3D WalkAround features through the menu it displays
along the top of the screen. This chapter describes these features.
Using Menus
Menu items that you cannot currently select are dim and will
not highlight. In some cases, you may need to select an object
or perform some other operation first.
You can access many frequently-used menu items using the
keyboard. These menu items are indicated with a command key
symbol and a keyboard character. For example, to choose
Undo, you can hold down the command key and press the letter
“Z”.
Note: A few keys are treated special by 3D WalkAround. To
provide even easier menu access, some keys also select menu
items without the command key held down. For example, to
rotate a selected object left, you can press “<“ without using
the command key. You can find a complete listing of command
keys in the Appendix.

Apple Menu
About
This shows information about 3D WalkAround such as the
copyright date, the company that published it, and the
programmer’s name.
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Status
Select Status for information about your active drawing, such
as its page size, scale, and the amount of free memory that’s
left or used.

File Menu
New
Select New to open a new, untitled document window. Up to 8
windows can be open at one time.
Open
Select Open from the File menu to bring up a file dialog and
open an existing drawing from disk.
Simply find the file you want in the file dialog and doubleclick it’s name or click the name once and click Open. If you
need additional help using the file dialog, please refer to the
Owner's Guide that came with your computer.
Note: 3D WalkAround tries to open its own proprietary file
type, Design Your Own Home: Architecture and Interiors files,
and PICT files. However, importing non-3D WalkAround files
may result in the loss of some information that 3D WalkAround
can’t use. For example, 3D WalkAround is object-oriented so
bitmap data in PICT files (data from paint programs or scanned
images) is ignored. In that case, try importing through the
clipboard using Paste As Pict.
Also, opening layouts created with a previous version of 3D
Walkaround is done automatically. However, if you save an
old layout with the current version, it may be incompatible
with the previous version. To avoid this problem, make a copy
of your previous version file before opening it in the new
version.
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Close
Select Close when you are completely finished with the drawing in the front-most window and want to remove the drawing
and the window from the desktop. You can also click a
window’s close box to accomplish the same thing.

If asked whether to save changes, click Yes if you want to keep
any changes and save the drawing to disk.
Save
Choose Save from the File menu to save the drawing in the
front-most window to disk. If the window is untitled, a dialog
appears so you can name it. Type a unique name for your
drawing, then click Save (see “Save As” for more).
If the drawing already has a name, you are not prompted for a
new name. The current name is used and the save is performed
immediately. This lets you quickly save an updated version of
your drawing.
To save even more quickly, hold down the command key and
press “S”.
Warning: Save replaces any previous version of your drawing
with your current version. To keep a previous version, use Save
As to give your current version a different name.
Use Save frequently so you’ll always have a recent version of
your drawing on disk. This provides added protection in case a
power failure occurs or your computer quits working for any
reason. If you update your disk version often, you’ll lose only a
few recent changes and not your entire drawing or hours of
work.
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Save As
Use Save As to save an untitled drawing, to save a drawing
under a different name, or to save to a different disk. After the
save, the name above the drawing window changes to the new
name.
In the file dialog, move to the disk location where you want
your drawing to be saved, type a name for it in the box provided for that purpose (below “Save document as:”), then click
the Save button. This saves the drawing into the current folder
and exits the save dialog.
Now that your drawing is saved, you can use Open from the
File menu to retrieve it at a later time. If you need additional
help using the file dialog, please refer to the Owner's Guide
that came with your computer.
Backup your work. If you’ve made many changes, use Save
As to save an additional backup copy of your work, preferably
to a floppy disk as well. If your original disk or file becomes
damaged, you can restore it from the backup copy. For important work, it's also a good idea to keep one additional copy of
the previous session’s work and not touch it during the current
work session. If, for some reason, both your current copy and
the backup is damaged, you’ll have the previous session’s work
to fall back on. For example, if a system failure causes your
original file to save incorrectly, the same problem will most
likely cause any backup to save incorrectly. Your only salvation may be an additional copy of your previous session’s
work.
Export
The Export menu item contains two submenus which let you
export (or save) a drawing as either a black and white PICT,
color PICT (PICT2) or Design Estimator document. Please
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refer to your product catalog or contact Abracadata for information about Design Estimator.
It’s important to save your work in the normal way with Save
or Save As also. 3D WalkAround only opens PICT2 documents
as a single PICT object, as with Paste As PICT. And, although
3D WalkAround does open black and white PICT files, some
information may be lost in the process.
Revert
This reloads the last version of a drawing that was saved to
disk.
Select Revert from the File menu if you’ve made changes since
last saving your work and decide that you don’t want to keep
the changes.
Browse
You can use Browse to look at or open 3D WalkAround,
Architecture, Interiors, and PICT drawings that are saved on a
disk.
To Browse a folder:
1. Select Browse from the File menu. A file dialog displays.
If you want, click the Drive or Desktop button to catalog a
different drive.
2. Double-click the file you want to see. You may also click
its name once and click Browse.
3. View the drawing then click the desired button. Click
Previous or Next to view additional drawings from the cataloged list, click Open to quit browsing and open the drawing,
or click Exit.
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Page Setup
Choose Page Setup from the File menu to set the paper size and
other printing options. This is optional. Standard settings are
used if you don’t change them.
After choosing Page Setup, the dialog you’ll see varies depending on the printer you have. If you aren’t using an Apple
printer, the driver supplied with your printer displays the dialog
and controls its content.
A brief description of some common options for the page setup
dialog follows. Please refer to your computer and printer
User’s Guide for more information about Page Setup and
printing documents.
US Letter. This is the default paper setting. Use it for normal
printing to the Laserwriter on paper that’s 8 1/2 by 11 inches.
US Legal. Use this option for paper that’s 8 1/2 by 14 inches.
A4 Letter. This option is for European standard paper. Its size
is 8 1/4 by 11 2/3 inches (210 by 296 mm).
B5 Letter. This option is for the Laserwriter only. Its paper
size is 15 by 11 inches (381 by 279 mm).
Portrait Orientation. This refers to the left orientation icon. It
lets you print drawings with the same upright orientation they
have on the screen.
Landscape Orientation. Select this to print sideways (turned
right 90 degrees).
Print
Select Print from the File menu to set the number of copies you
want, the page range, and to print the drawing in the front-most
window.
If you have problems printing, you may need to install printer
resources or use the Chooser desk accessory (under the Apple
91

Chapter 4, Menus
menu) to specify the type of printer you have and how it is
connected to your computer.
As with Page Setup, the print dialog you’ll see varies depending on the printer setup you have. If you aren’t using an Apple
printer, the driver supplied with your printer displays the dialog
and controls its content. Please refer to your computer and
printer User’s Guide if you need help installing printer resources, using the Chooser, and for additional printing information. Following is a brief description of common options.
Copies. Type the number of copies you want to print.
Pages. This sets the range of pages you want to print for
multiple-page drawings. Normally, you’ll print an entire
drawing; however, you have the option of specifying which
pages to print. The pages print in vertical columns numbered as
illustrated here:
4 page drawing
1 3

2 x 3 page drawing
1 4

2 4

2
3

5
6

After setting the printing options, click the Ok button to start
printing. Remember to make sure your printer is on and ready
for printing. You can hold down the command key and press
“.” to stop printing.
Quit
Select Quit from the File menu when you are completely
finished using 3D WalkAround.

Edit Menu
Most choices under the Edit menu work with objects you select
with the selector tool, or text you select with the text tool.
These items are dim and unavailable until you select one or
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more objects, or text. See “Selecting Objects” in the “Tools”
chapter if you need help.
Undo
Choose Undo to reverse the last change made to a drawing. In
most instances, you can select it again and reverse the undo
(restore the last change you made).
Undo reverses the last operation performed so use it right away
if you make a mistake. It may be dim and unavailable if you
click in a window or perform some other operation first.
Cut
Cut lets you remove selected objects from your drawing and
place them in the clipboard.
To Cut objects:
1. Click the selector tool.
2. Click the object(s) you want to remove, then choose Cut.
You can also hold the command key and press the letter “X”.

You can choose Show Clipboard from the Edit menu to view
the clipboard’s contents (see “Show Clipboard”). Use Paste to
insert the clipboard’s contents into the front-most window (see
“Paste”).
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Copy
Copy lets you place a copy of selected objects in the clipboard
without removing them from your drawing.
To Copy objects:
1. Click the selector tool.
2. Click the object(s) you want to copy, then choose Copy.
You can also hold the command key and press the letter “C”.

Selected objects are left in your drawing and a duplicate copy
of them is placed into the clipboard.
Paste
Paste lets you copy the clipboard’s contents into the front-most
window. Choose Show Clipboard from the Edit menu to view
the clipboard’s contents.
To Paste the clipboard’s contents into a drawing: If the
window that you want to paste into is not currently the frontmost window, click any part of it to bring it to the front. Select
Paste from the Edit menu (or hold the command key and press
the letter “V”). The pasted objects appear in the window and
the selector tool is activated so you can easily move the objects
to the desired position.

94

Chapter 4, Menus
Clear
Clear lets you remove unwanted objects from the front-most
window. You can also press the delete key to perform a clear.
The objects are not placed in the clipboard. Use Cut to remove
objects and place them in the clipboard.
To Clear objects:
1. Click the selector tool.
2. Click the object(s) you want to remove, then choose
Clear or press the delete key.
Selected objects are removed from your drawing. You can
immediately choose Undo from the Edit menu to restore the
deleted objects.
Select All
Choose Select All or hold down the command key and press
the letter “A” to quickly select every object in the front-most
window. If you are using the text tool and have typed text, this
selects all of the text.
Duplicate
You can perform the equivalent of a Copy and Paste in one
operation by selecting Duplicate.
To Duplicate objects:
1. Click the selector tool.
2. Click the object(s) you want a copy of, then choose
Duplicate. You can also hold the command key and press the
letter “D”.
A duplicate copy of the selected objects is placed in the clipboard and pasted back into your drawing. Since a copy is in the
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clipboard, you can continue to paste additional copies using
Paste.
Multiple Duplicate
Select an object, then choose Multiple Duplicate to display a
parameters dialog for copying an object(s) a specified number
of times.

Number of copies. Type the number of additional copies to
make.
Offsets. This is the amount of space to use between each copy.
You can specify a horizontal and vertical offset in either pixels
(screen dots) or scaled distances such as 10", 2’6", or 2.5. Use
a negative offset to duplicate toward the left (horizontal) or
upward (vertical). Use the same amount for the horizontal and
vertical offsets to move at 45 degree angles, and use zero for
either of the offsets (but not both) to move in straight lines.
Dynamically changing the offsets. If desired, you can increase or decrease an offset by a specified percentage between
each copy. Use a zero percentage to keep an offset constant, or
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type the desired percentage. For example, 50% increases or
decreases (depending on the option you choose) an offset by
half it’s previous amount between each copy. Using different
horizontal and vertical percentages and offsets lets you create a
series of objects along a curved path.
Setting the regular Duplicate offsets. You can also use this
dialog to set the offsets for the regular Duplicate menu item.
Simply click the box next to the option provided for this purpose. Then, if the number of copies specified is zero, no multiple duplicate is performed. Instead, the regular duplicate
offsets are set to those shown in the dialog (the regular
duplicate’s defaults are 12 pixels). If this option is enabled and
the number of copies is greater than zero, then the regular
duplicate offsets are set, and the multiple duplicate is performed.
To do a multiple duplicate:
1. Activate the selector tool and select an object.
2. Choose Multiple Duplicate and set the desired parameters.
3. Click Duplicate. Here’s an example of a multiple duplicate
that specified 5 copies, used 4 pixels for both offsets, and
dynamically increased the horizontal offset by 50%.
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Copy As Color PICT2
This works exactly like copy, except selected objects are
placed in the clipboard as a color PICT2 document for possible
exporting to other applications. The regular Copy menu item
places a black and white PICT in the clipboard.
Paste As PICT
3D WalkAround is an object oriented drawing program, so it
does not fully support bitmap image editing (from paint programs, scanners, etc.). However, it does support importing
virtually any type of image, including bitmaps, and color, as
PICT objects.
Use Paste As PICT to paste the clipboard’s contents, whether
bitmap images, or other objects, into a drawing and have them
treated as a single PICT (or PICT2) object. A PICT object may
be moved, resized, duplicated, and deleted using the selector
tool, but is otherwise unchangeable.
Show Clipboard
Choose Show Clipboard to view the current contents of the
clipboard.
If you select Paste, a copy of the clipboard’s contents is inserted into the front-most window. You use Cut, Copy, or
Duplicate to put objects or text into the clipboard.
Change To Polygon
Sometimes you may find it convenient to change other objects
such as ovals, arcs, rectangles, etc. into polygons. Afterwards,
you can use the shaper tool to edit their vertices (see the
“Shaper Tool” section for more about it).
To change an object into a polygon:
1. Click the selector tool and select the object.
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2. Choose Change To Polygon. Here’s an example that
changes a rectangle into a polygon, then reshapes it using the
shaper tool.

Change Line To Wall
Choose this to change all lines selected with the selector tool
into wall objects that will display in the 3D view. This might
be useful for converting older imported Design Your Own
Home floorplan walls.
Set Floor/Ceiling Altitudes

This option is used to create slanted floors and ceilings. To create
a slanted floor or ceiling, simply enter the desired altitude for each
point of the floor or ceiling. Change points by using the arrows
until the desired point is selected. The sides of the floor or ceiling
will slant proportionally between the two adjacent points.
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Edit Patterns, Default Patterns
If you’ve customized the pattern palette using Edit Patterns,
you can choose Default Patterns from the Edit Menu to replace
the custom patterns with those that were originally provided
with 3D WalkAround. You cannot undo this operation, so be
certain that you want to discard the custom patterns!
Please see “Editing Patterns” in the “3D WalkAround Tutorial”
chapter for additional information and for how to edit patterns.
Object Info
Choose this to obtain information about a selected object. The
type of information varies depending on the kind of object it is.
You may select and view information for only one object at a
time. Object Info is dim and unavailable otherwise.
Set Object 3D Info
Please refer to “Setting 3D Textures And Object Info” in the
tutorial chapter for a description of this feature.
Set Estimator Info
This lets you specify the settings that are exported with Export
- Estimator File under the File menu for Abracadata’s companion product, Design Estimator. Please see the product catalog
or contact Abracadata for more information about Design
Estimator.

Arrange Menu
All the items under the Arrange menu work with selected
objects. If you need help selecting objects, please see “Selecting Objects” in the “Tools” chapter.
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Bring Forward, Send Backward, Bring To Front, Send To
Back
These menu items let you adjust the stacking order of selected
objects. Use Bring Forward and Send Backward to move an
object in front of, or behind, the first overlapping object that is
found. Choose Bring To Front to move an object in front of all
other objects, or use Send To Back to place it behind (beneath)
all other objects.
To bring an object forward:
1. Click the selector tool.
2. Select the object(s) you want to bring forward, then choose
the desired menu item.

Follow the same procedure to send an object to the back.
Rotate By Degrees
Please see “Rotating Objects” in the “3D WalkAround Tutorial” chapter for step-by-step instructions about rotating objects.
Rotate Left, Rotate Right
Please see “Rotating Objects” in the “3D WalkAround Tutorial” chapter for step-by-step instructions about rotating objects.
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Flip Horizontal, Flip Vertical
Choose these menu items to flip the orientation of selected
objects from left to right, or top to bottom.
To flip an object horizontally:
1. Click the selector tool.
2. Select the object(s) you want to flip, then choose Flip
Horizontal. You can also press “”” (quote) without using the
command or shift key.

Follow the same procedure to flip an object vertically, choosing Flip Vertical instead (or press “:” without using the command or shift key).
Group, Ungroup
Group converts a collection of objects selected with the selector tool into a single grouped unit.
Once grouped, the objects are treated as a single object until
they are ungrouped. For example, if you select a grouped
object, then select a pattern, all the individual objects within
the group take on the pattern.
To group objects:
1. Click the selector tool.
2. Select the objects you want to group, then choose Group.
You can also hold the command key and press the letter “G”.
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Use Ungroup (command - “U”) to separate grouped objects
into their individual component objects again.
Lock, Unlock
You can use Lock to keep objects from being moved, grouped,
deleted, or otherwise changed.
To lock an object:
1. Click the selector tool.
2. Select the object you want to make unchangeable, then
choose Lock. You can also hold down the command key and
press the letter “K”.

Notice that the locked object has dimmed handles, indicating
the object is locked. Use Unlock (command - “J”) to make
locked objects changeable again.
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Align
Align lets you align a series of objects vertically by their top,
center, or bottom positions, or you can align them horizontally
by their left, center, or right positions.

Click the None option for no alignment, or choose the desired
alignment. The sample objects in the dialog take on the chosen
alignment.
To align a series of objects:
1. Click the selector tool and select the objects.
2. Align the objects. Choose Align, set the desired alignment,
then click the Align button. Here’s an example that aligns 3
objects by their horizontal centers (the None setting was used
for the vertical alignment).
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Distribute
This lets you distribute a series of objects vertically by their
tops, centers, bottoms, or edges, or you can distribute them
horizontally in the same fashion.
To distribute a series of objects:
1. Click the selector tool and select the objects.
2. Distribute the objects. Choose Distribute, set the desired
options. Use the example shown in the dialog as a reference to
see how the objects will distribute based on the chosen options.
Click the Distribute button to distribute selected objects accordingly.
Align to Grid
If grid snap is enabled, you can use Align to grid to align a
selected object to the grid, using the coordinates of the object's
upper left corner. If you want, you can select Show Grid Points
from the Layout menu to see the grid.
The following instructions assume grid snap is enabled. Please
see "Using Snap" in the tutorial chapter for how to turn on grid
snap.
To align an object to the grid:
1. Click the selector tool.
2. Select the object you want to align.
3. Choose Align to Grid from the Arrange menu. The object
aligns to the grid.
Scale Selection
You can rescale existing objects by a given percentage using
Scale Selection.
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To rescale an object:
1. Click the selector tool.
2. Select one or more objects to rescale.
3. Choose Scale Selection and type the scaling percentage.
Type a percentage, then click Scale to initiate the rescaling of
selected objects. For example, type 50 percent to reduce objects by one-half, or type 200 percent to double their size.

Text Menu

Font, Size, Style
As their names imply, the Font, Size, and Style menu items let
you pick a font, it’s size, and style. Your choices are used the
next time you type with the text tool.
If a text object is selected, or you are currently typing text with
the text tool, it also changes to the chosen font, size, or style.
This lets you easily experiment and change existing text. See
“Editing Existing Text” for more detailed information.
Font. Choose the font you want to use from the Font submenu.
Size. When you look at the size choices for a given font, you
may notice that one or more of the sizes are shown with outlined numbers.
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Outlined numbers indicate the sizes for which a real font
actually exists. A font looks best at the outlined sizes. When
you choose a size that isn’t outlined, the font is scaled to the
size.
Other. Choose Other from the Size submenu to specify a font
size that isn’t provided by the menu’s size choices.
Style. A font’s style refers to the way it looks. Style choices
include plain, bold, italic, underline, outline, and shadow.
Here’s how they look:

Except for plain, which cancels all other styles, the styles are
accumulative. For example, it’s okay to use bold and outline at
the same time.
Left, Center, Right
Use these menu items to specify how you want selected text, or
text you type, to be aligned.

The chosen alignment is used by the text tool the next time you
type text.
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If you have a text object selected, or are typing text, it also
takes on the new alignment. See “Editing Existing Text” for
more related information.
Single Space, 1-1/2 Space, Double Space
These choices let you set the spacing between lines of text.
Single spacing is the normal spacing.

The chosen spacing is used by the text tool the next time you
type text and press the return key. Any existing text objects
selected with the selector tool also change to the new spacing.
See “Editing Existing Text” for more related information.

Line Menu
Set line and object border widths by choosing the size you
want under the Line menu. Please see “Setting Line Thicknesses” in the “Tools” chapter and “Using Patterns” in the
tutorial chapter for additional information.

Color Menu
Use the Color menu items to change existing object colors or to
specify colors to use when drawing. Please see “Using Colors”
in the tutorial chapter for detailed information about working
with colors.
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Symbols Menu
Library, Open Library Window
Please refer to “Creating A Drawing” and “Using Symbol
Libraries” in the tutorial chapter for a complete description of
these menu items.
3D Preview
Selecting this option will bring up a 3D Preview of any selected object. Click on the Nearer and Farther buttons to cause
the object to approach or recede. To rotate the object, click on
the Adjust button and use the mouse (with the button depressed) to view the object from the desired angle. Use the
Reset button to restore the original view.

Layout Menu
Overview
Select Overview from the Layout menu to see a scaled down
version of your whole drawing.
Show 3D View
Selecting this option has the same effect as using the 3D button
on the toolbar. By selecting this option, your 3D Window will
be displayed.
Layers
Please see “Using Multiple Layers” in the tutorial chapter for
detailed information about layers.
Snap
Please see “Using Snap” in the tutorial chapter for detailed
information about object and grid snapping.
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Scale
Choose Scale to set the drawing scale and units you want to
work within. The following dialog displays:

A description of the various options follows.
Scale. Click the button beside the desired scale. See “Choosing
A Scale” below for help picking the best scale for your project.
Units. Click the button next to the type of units you want,
either feet-inches or centimeters. If you select centimeters, the
scale choices change to metric scales.
Rescale drawing. Click the box beside this option if you want
objects rescaled (resized) when you change scales. See “About
Changing Scales” for additional information.
Choosing A Scale
It's best to do some planning before choosing a scale. When 3D
WalkAround begins, the scale is 1/8" = 1' (unless you change
the preferences). This means when you print a hard copy, 1
inch on paper is equal to 8 feet in the real world. Since a onepage, printed drawing is 8 inches wide (using the U.S. Letter
page size from the Page Setup item), the real-world width of a
page is 64 feet and the height is 84', using the start-up scale
(note that you can Show Rulers and reference page breaks to
help determine scaled page sizes).
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If the design you are beginning will be larger than 64 feet wide,
then you’ll need to set a drawing size larger than one page, or
choose a different scale if you want to keep your drawing size
to one printed page (multiple-page drawings print on 2 or more
pages of paper - see “Drawing Size” later in this chapter).
Each scale choice increases or decreases the drawing’s realworld width and height. For example, if you choose 1/16" = 1',
your drawing’s page width increases to 128 feet (16' x 8 inches
per page). The maximum page width for the scale choices is
8000' using the 1" = 1000' scale. If you need a drawing to be
wider than 8000', you must select Drawing Size and create a
multiple-page drawing, which can be up to 8x8 pages in size
(up to 64000' in width).
The following list shows the width of a page for each of the
scale choices using the U.S. Letter paper size.
Scale
1/32" =
1/16" =
1/8" =
1/4" =
1/2" =
1"
=
1"
=
1"
=
1"
=
1"
=
1"
=
1"
=

1'
1'
1'
1'
1'
1'
6'
10'
20'
50'
100'
1000'

Page Width
256'
128'
64'
32'
16'
8'
48'
80'
160'
400'
800'
8000'

About Changing Scales
Although 3D WalkAround rescales existing objects when you
change scales, it’s much better to choose the correct scale
before you begin drawing and stay with that scale. Due to
rounding, differences in line widths, screen resolution, etc.,
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objects may become misaligned and distorted to some degree
during the rescaling process.
Scale changes may also force the page size of a drawing to
change. For example, a single-page drawing may become a
multiple-page drawing if a scale change causes objects to grow
in size, since they may extend beyond the boundary of a single
page.
For the reasons mentioned above, before you rescale an existing drawing, always save a copy to disk as a safeguard first!
Once objects have rescaled during a scale change, you may not
be able to simply go back to the original scale and have them
be as they were. The next scale change rescales objects based
on their new, possibly slightly distorted, size.
Note that text is repositioned but not rescaled when you change
scales because it can become unreadable with a relatively small
scale change. If you need to, you can select the text and use
Size under the Text menu to change its size.
Wall Tool
Please refer to “Wall Tool” in the “Tools” chapter for a description of this menu item.
Floor Tool
Please see “Floor Tool” in the “Tools” chapter for a description
of this feature.
Stud Tool
This menu item lets you change the parameters for the Stud
tool. The changes are used the next time you use the Stud tool.
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Spacing, O.C. O.C. stands for a contractor's term, On Center.
It's the spacing between studs, measured from the center of one
board to the center of the next adjacent board. You can change
the O.C. spacing for studs by clicking the circle next to the
spacing you want, or by clicking the box next to Other and
typing in the amount of spacing you want.
Board Size. If you want to change the board size, click the box
next to the measurement you want to change and type in the
new measurement.
Orientation. Change the orientation of the boards by clicking
the desired orientation icon. The current orientation is highlighted. The first four orientations are side views, the last four
are end views.
When you're using the stud tool with a side view orientation,
the length of the studs is determined by the size of rectangle
you draw. The area the rectangle encloses is filled with studs.
Here's an example using a vertical orientation.
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If you have chosen a top view orientation, the length of the
studs is determined by what you specify under Board Size in
the settings dialog. The length is used for the information that
appears in the Object Info dialog (from the Edit menu). Please
see "Stud Tool" in the "Tools" chapter for more about drawing
studs.
Measure Tool
Please see “Measuring And Using Reference Markers” in the
tutorial chapter for a detailed description of this tool’s setting’s
dialog, and its use.
Multigon Tool
Please see “Multigon Tool” in the “Tools” chapter for a detailed description of this tool’s settings dialog.
Window Tool & Door Tool
The Window and Door tools have exactly the same features.
The 3D Altitude value is for setting the height of the object
above the floor. The 3D Height value is for changing the height
of the object itself. The Width value sets the object width.
The Change 3D Object button allows you to select different
windows and doors from the included libraries.
Checking the box next to “Apply to Selected Windows/Doors”
changes the properties of the currently selected objects.
The preview window operates exactly like the 3D Preview
option in the Layout Menu.
Roof Object Tool
Selecting this option will bring up a dialog displaying roof
object properties.
The 3D Altitude value is for setting the height of the roof
above the floor.
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The Change 3D Object button allows you to select different
roof objects from the included libraries.
Checking the box next to “Apply to Selected Roofs” changes
the properties of the currently selected roof objects.
The preview window operates exactly like the 3D Preview
option in the Layout Menu.
Auto Roof Tool
Selecting this option allows you to view the default properties
for the Auto Roof Tool.
There are four options from which to base the 3D altitude of
your auto-roof. Choosing “Lowest Wall’s Height” will place
the bottom of the roof on the top of the lowest wall. Choosing
“Highest Wall’s Height” will place the bottom of the roof on
the top of the highest wall. Choosing “Selected Wall’s Height”
will place the bottom of the roof on the top of the currently
selected wall. Choosing “Custom” allows you to enter the
height at which the bottom of the roof is set.
The value in the “Roof Overhang” box allows you to set the
distance at which the roof extends beyond the walls.
The value in the “Roof Height” box allows you to set the
height from roof base to roof top.
Drawing Size
You use Drawing Size to change the page size of your drawing,
which increases or decreases the amount of space inside the
drawing window. Each page in size corresponds to a printed
page on paper. In some cases, you may want to print multiple
page drawings, then trim the edges off the paper and attach the
pages together.
When 3D WalkAround begins, the drawing size is set to 1 page
wide by 1 page high (unless you save new preferences). You can
create drawings that are up to 8 x 8 pages in size. However, you
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should limit the size to what you really need for a given project.
Remember that an 8 x 8 page drawing contains a total of 64 pages,
which could take a considerable amount of time to print. The
width and height do not have to be the same. The following
drawing size examples are all okay:
Pages Wide x Pages High
1x2
2x1
2x2
2x4
4x4
To change the drawing size:
1. Select Drawing Size from the Layout menu. A dialog
containing a grid of boxes appears.

Each box represents one page.
2. Set the desired size. Move the pointer onto the grid and
click (or hold the button down and drag) to reduce or enlarge
the drawing size. Click the Ok button when the size is what
you want.
If you are changing the size of an existing drawing, you can’t
reduce its size below the number of pages that are currently
used. You can select Status from the Apple menu to see a
drawing’s current size.
116

Chapter 4, Menus
In some cases, a drawing’s page size may change automatically. For example, if you use Page Setup and choose a paper
size (page size) that is smaller than the current size, existing
objects may extend beyond the boundaries for the new page
size. If so, additional pages are added. This might occur when
you change scales, too. If any rescaled objects extend beyond
the drawing’s current width or height, the drawing's size is
automatically enlarged.
Preferences
Choose Preferences to specify the configuration of drawing
windows that are created by New under the File menu, and to
set other preferences.
Enable and disable the desired preferences by clicking the
boxes next to them, then click Save to retain and use the settings.
Show/Hide Markers
This lets you show or hide reference markers that are optionally created by the measure tool. Please see “Measuring And
Using Reference Markers” in the “Tools” chapter for more
information.
Show/Hide Rulers
Choose Show Rulers if you want visible rulers while drawing.
If rulers are currently being used, this item changes to Hide
Rulers.
The ruler units change depending on the scale. Where the
rulers meet at the top left corner of the drawing window, you’ll
see an abbreviation, "ft", "in", or "cm", indicating the working
unit.

117

Chapter 4, Menus

Show/Hide Ruler Lines
Select this to show and hide ruler reference lines that you may
find helpful for drawing and positioning symbols more precisely.

Show/Hide Page Breaks
This lets you show or hide striped lines that indicate where
each page of a multiple-page drawing begins and ends.

Since each page in a drawing corresponds to a printed page on
paper, you’ll probably want to show page breaks if your drawing is more than one page in size, and it doesn’t hurt to leave
them visible all the time.
Show/Hide Grid Points
Use this item to show or hide grid points. If grid snap is
enabled, any object you draw will snap to the nearest grid
points.
Show/Hide Measurements
Choose this to show or hide size measurements that appear as
you stretch an object to size (when you draw).
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For box, oval, and arc object, width and height measurements
appear. Length and angle measurements are shown for line
objects. Here’s an example of what you’ll see.

The measurements are useful when you need to draw lines or
other objects (to scale) to a specific size. You can find an
existing object’s size by selecting it and choosing Object Info
from the Edit menu.
Turn On/Off Scrolling
When you turn on scrolling, your drawing will scroll automatically if you draw beyond the edge of the window. This makes
drawing objects that are larger than the viewing area much
easier.
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Command Keys
Menu Command Keys
File Menu
Cmd-N
Cmd-O
Cmd-W
Cmd-S
Cmd-P
Cmd-Q

New
Open
Close
Save
Print
Quit

Edit Menu
Cmd-Z
Cmd-X
Cmd-V
Cmd-D
Cmd-A
Cmd-I
Cmd-E

Undo
Cut
Paste
Duplicate
Select All
Object Info
Set Object 3D Info

Arrange Menu
Cmd-F
Cmd-B
Cmd-,
Cmd-.
Cmd-’
Cmd-;
Cmd-G
Cmd-U
Cmd-K
Cmd-J

Bring Forward
Send Backward
Rotate Left
Rotate Right
Flip Horizontal
Flip Vertical
Group
Ungroup
Lock
Unlock
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Command Keys
Symbol Menu
Cmd-Y
Cmd-L

Library
Open Library Window

Layout Menu
Cmd-H
Cmd-R
Cmd-Cmd-M

Overview
Show/Hide Rulers
Show/Hide Ruler Lines
Show/Hide Measurements

Other Command/Modifier/Hot Keys
Note: Unless indicated, don’t hold down the command key.
2D Layout Window
Hot keys for selecting tools:
g
Grabber tool
r
Rotate tool
e
Eyedropper tool
m
Measure tool
s
Shaper tool
l
Line tool
c
Constrained line tool
h
Hollow line tool
w
Wall tool
b
Rectangle tool (box)
x
Rounded rectangle tool
o
Oval tool
a
Arc tool
p
Polygon tool
k
Sketch tool
d
Stud tool
z
Bezier tool
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Command Keys
m
t
f
space bar

Multigon tool
Text tool
Floor tool
Toggles back and forth between current tool
and selector tool

Miscellaneous hot keys and modifiers:
Arrows
Move selected objects, or last object drawn
when using drawing tools
+
Zoom in (don’t need to hold shift)
Zoom out
<
Rotate left (90 degrees)
>
Rotate right (90 degrees)
“
Flip Horizontal
;
Flip Vertical
1–8
Set line/border thickness
9
Dimension line
0
No line/border (same as not equal pattern
symbol)
command
Hold using selector, then drag objects to
create duplicates, or to drag between different
document windows
shift
Hold while drawing for perfect circles,
squares, 45 degree line angles
shift
Hold using selection tools to select/deselect
additional objects
command
Hold while drawing to temporarily disable all
snapping options
command
Hold using eyedropper tool to transfer colors
between objects
option
Hold using eyedropper tool to transfer patterns between objects
command
Hold and click the on-screen Layer button to
go to first layer
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Command Keys
option
command
option
option

Hold using measuring tool to change between
line/rectangular measuring
Hold using measuring tool to override reference marker usage option
Hold using shaper to cut polygon line segments and delete vertices/handles
Hold when selecting Open Library Window
to display symbols in columns (more efficient
if a printout is desired)

3D Window
command

Arrows
shift
option
control

Hold when clicking 3D button to reset 3D
view background color to the original default
(use color dialog to change 3D background
color)
Use to walk-around in 3D view
Hold to turn in place (or rotate) when performing left/right 3D movement
Hold to move higher/lower in altitude when
performing up/down 3D movement
Hold to tilt when performing up/down 3D
movement
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